cancel
Showing results for 
Search instead for 
Did you mean: 

I keep getting the message "This search engine isn't supported by Firefox and can't be installed" whenever I try to install ANY search plugin on the Mozilla Add-ons website. Why?

SOLVED
Highlighted
New Contributor

I keep getting the message "This search engine isn't supported by Firefox and can't be installed" whenever I try to install ANY search plugin on the Mozilla Add-ons website. Why?

No matter which search plugin I choose to install from the list of FireFox search plugins on the Mozilla Add-ons website, I get the same error message - "This search engine isn't supported by FireFox and can't be installed". I tried deleting the 3 files in my profile identified in the article on troubleshooting plugins, but it didn't help. I am running Firefox with administrator privileges, but that doesn't help. The problem appears to be only with search plugins. I can install other extensions that are not search plugins from the Mozilla Add-ons site, but not search plugins. I tried restarting FireFox and rebooting the computer severaltimes, but I keep getting the same error message when I try to install a search plugin.

1 ACCEPTED SOLUTION

Accepted Solutions
Support Forum Moderator

Re: I keep getting the message "This search engine isn't supported by Firefox and can't be installed" whenever I try to install ANY search plugin on the Mozilla Add-ons website. Why?

Something is messed up on the AMO seacrh plugins pages. Try clearing the URL bar and type anything there (but don't hit Enter) - then you should be able to proceed with installing a search plugin.

4 REPLIES
Support Forum Moderator

Re: I keep getting the message "This search engine isn't supported by Firefox and can't be installed" whenever I try to install ANY search plugin on the Mozilla Add-ons website. Why?

Something is messed up on the AMO seacrh plugins pages. Try clearing the URL bar and type anything there (but don't hit Enter) - then you should be able to proceed with installing a search plugin.

Site Moderator

Re: I keep getting the message "This search engine isn't supported by Firefox and can't be installed" whenever I try to install ANY search plugin on the Mozilla Add-ons website. Why?

Does it work on the Mycroft website?

New Contributor

Re: I keep getting the message "This search engine isn't supported by Firefox and can't be installed" whenever I try to install ANY search plugin on the Mozilla Add-ons website. Why?

WOW!! That worked! Thank you so much for your help!  :-)

New Contributor

Re: I keep getting the message "This search engine isn't supported by Firefox and can't be installed" whenever I try to install ANY search plugin on the Mozilla Add-ons website. Why?

If you are creating your own search plugins, be aware that you will get this same error if the path to the XML in your action script must be an absolute URL, even if the XML file is in the same location as the page that is pointing to it.

IOW, this will never work:

  • window.external.AddSearchProvider('MySearchDefinition.xml');

it must be: