cancel
Showing results for 
Search instead for 
Did you mean: 

I have 14.0.1 but websites are telling me I need the newest FF in order to work!

Highlighted
New User

I have 14.0.1 but websites are telling me I need the newest FF in order to work!

I have Firefox 14.0.1 Facebook 'words with friends' game says Sorry ~ it appears you are using a browser that is not currently supported. Please use one of the following Firefox 3.6+

Also, the Pizza Pizza website says that I need to upgrade my browser also. I did! But I still can't access their new site because apparently I don't have the newest Firefox. But I do!!!

What more can I do!??!?

2 REPLIES
Expert User

Re: I have 14.0.1 but websites are telling me I need the newest FF in order to work!

Hi,

You can check the installed version via Help (Alt + H) > About Firefox. Your Firefox version is being detected on websites as 3.5.4 (please see the section on the top right). You can try to filter for the word useragent in about:config, right-click on every instance and Reset.

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.

about:config Entries

SUMO Contributor

Re: I have 14.0.1 but websites are telling me I need the newest FF in order to work!

This article in the Knowledge Base has more background on the issue: Websites say that Firefox is outdated or incompatible even though it's the latest version.