cancel
Showing results for 
Search instead for 
Did you mean: 

I do not have the money to buy a new computer and wish not to be vulnerable using your latest version of Firefox. I want to stay with the previous version.

SOLVED
Highlighted
New Contributor

I do not have the money to buy a new computer and wish not to be vulnerable using your latest version of Firefox. I want to stay with the previous version.

I saw a previous question from a windows user, but it seemed like it was from a very long time ago (talking about the 3.x.x editions), and all the links on that thread seemed to only have updates of 3. I just want to stay with the version of Firefox before this latest update (10/30/12) that say 16.0.2 doesn't work well with my older Mac OSX. Can you provide me a link to reinstall that, and forgive my ignorance, but let me know exactly what I need to do to avoid losing preferences and bookmarks and such? Thanks very much.

1 ACCEPTED SOLUTION

Accepted Solutions
Site Moderator

Re: I do not have the money to buy a new computer and wish not to be vulnerable using your latest version of Firefox. I want to stay with the previous version.

All Firefox 16 versions still work with your OS X 10.5 operating system, but that is the last version that will work.
Firefox 17 will require OS X 10.6 and later.

You can see the Firefox 17 (currently in beta) system requirements here: http://www.mozilla.org/en-US/firefox/17.0/system-requirements/

2 REPLIES
Site Moderator

Re: I do not have the money to buy a new computer and wish not to be vulnerable using your latest version of Firefox. I want to stay with the previous version.

The version of Firefox that you have installed (16.0.2) is the most secure version available for your mac. Any previous version is going to be less secure than that. Firefox no longer works with Mac OS X 10.5

Site Moderator

Re: I do not have the money to buy a new computer and wish not to be vulnerable using your latest version of Firefox. I want to stay with the previous version.

All Firefox 16 versions still work with your OS X 10.5 operating system, but that is the last version that will work.
Firefox 17 will require OS X 10.6 and later.

You can see the Firefox 17 (currently in beta) system requirements here: http://www.mozilla.org/en-US/firefox/17.0/system-requirements/