cancel
Showing results for 
Search instead for 
Did you mean: 

I cannot get into BBC because I need an adobe flash player to do so, I was asked what # Firefox I have.

Highlighted
New User

I cannot get into BBC because I need an adobe flash player to do so, I was asked what # Firefox I have.

I am trying to get on the bbc radio 3 website

1 REPLY
Site Moderator

Re: I cannot get into BBC because I need an adobe flash player to do so, I was asked what # Firefox I have.

Does work here.

Your system details list shows an old Shockwave Flash 10.0 r32 plugin that may not work with the BBC side.
It does work with the latest Flash player for Firefox 3.6.x and that is Flash 10.3 r183.

The Firefox 3.6.24 version that you currently run is no longer supported with security updates

You should update the Firefox 15.0.1 and install the latest Flash player.

You can find the latest Firefox release in all languages and for all Operating Systems here: