cancel
Showing results for 
Search instead for 
Did you mean: 

I can't play games on GSN or Pogo when using Firefox; any suggestions on how to fix this?

Highlighted
New User

I can't play games on GSN or Pogo when using Firefox; any suggestions on how to fix this?

I can get into the websites, but when I try to load games; I get error messages and they will not load. I downloaded Java; but still doesn't work. Thanks.

1 REPLY
Shooting Star

Re: I can't play games on GSN or Pogo when using Firefox; any suggestions on how to fix this?

If they are Java games, you have a very, very, very old version of Java. Remove it (instructions below), then install the latest version.



The information submitted with your question indicates that you have out of date plugins with known security issues that should be updated. To see the plugins submitted with your question, click "More system details..." to the right of your original question post.

  • Java Plug-in 1.4.2 for Netscape Navigator (DLL Helper)
  1. Check your plugin versions: http://www.mozilla.com/en-US/plugincheck/
    • Note: plugin check page does not have information on all plugin versions
  2. Update Java: