cancel
Showing results for 
Search instead for 
Did you mean: 

I can not update my flash player because it say: Flash Player Plugin between 11.0 and 11.6.602.175 has been blocked for your protection

Highlighted
New User

I can not update my flash player because it say: Flash Player Plugin between 11.0 and 11.6.602.175 has been blocked for your protection

when i want to see a video or play, it says: update your flash player, but i can not do that. it says it has been blocked. now what should i do? should i instal an old version or not? OS: windows 8, firefox:21.0 thank you

1 REPLY
Site Moderator

Re: I can not update my flash player because it say: Flash Player Plugin between 11.0 and 11.6.602.175 has been blocked for your protection

hello bmkourosh, please refer to Why do I have to click to activate plugins?

you can download the latest version of the flash plugin from https://get.adobe.com/flashplayer/