cancel
Showing results for 
Search instead for 
Did you mean: 

I am running a Mac 10.5.8 and your software says it should be compatible with 10.5, yet it says it is incompatible with my operating system. Why?

SOLVED
Highlighted
New User

I am running a Mac 10.5.8 and your software says it should be compatible with 10.5, yet it says it is incompatible with my operating system. Why?

I am running a Mac 10.5.8 and your software says it should be compatible with 10.5, yet it says it is incompatible with my operating system. Why?

1 ACCEPTED SOLUTION

Accepted Solutions
Mozilla Support Contributor

Re: I am running a Mac 10.5.8 and your software says it should be compatible with 10.5, yet it says it is incompatible with my operating system. Why?

10.5.8 it is compatible with 10.0 firefox only with Intel processor see:

http://www.mozilla.org/en-US/firefox/10.0/system-requirements/

for your ppc mac the latest is the version you have 3.6.26 see:

http://www.mozilla.org/en-US/firefox/3.6/system-requirements/


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

7 REPLIES
Mozilla Support Contributor

Re: I am running a Mac 10.5.8 and your software says it should be compatible with 10.5, yet it says it is incompatible with my operating system. Why?

10.5.8 it is compatible with 10.0 firefox only with Intel processor see:

http://www.mozilla.org/en-US/firefox/10.0/system-requirements/

for your ppc mac the latest is the version you have 3.6.26 see:

http://www.mozilla.org/en-US/firefox/3.6/system-requirements/


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

New User

Re: I am running a Mac 10.5.8 and your software says it should be compatible with 10.5, yet it says it is incompatible with my operating system. Why?

Thanks for your help. It just said "recommended" so I didn't realize it was "required". Pretty stupid move, Mozilla - what are we supposed to do if we don't have the intel processor? Switch to Safari? Will you be coming out with a version for us?

Mozilla Support Contributor

Re: I am running a Mac 10.5.8 and your software says it should be compatible with 10.5, yet it says it is incompatible with my operating system. Why?

3.6.26 is fully supported till latest days of April, see if you like, TenFourFox (made from Mac Users) for PowerPC's running Mac 10.4.11 & 10.5.8

http://www.floodgap.com/software/tenfourfox/

http://tenfourfox.blogspot.com/

https://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported


thanks again

New User

Re: I am running a Mac 10.5.8 and your software says it should be compatible with 10.5, yet it says it is incompatible with my operating system. Why?

I don't suppose there is any chance of extending support for FX 3.6 beyond April? TenFourFox is a nice project, but it has various problems. See:

http://forums.mozillazine.org/viewtopic.php?f=23&t=2323835

for an extensive discussion of this issue. I know that 3.6 is old, but it is the last secure, stable browser for PPC users. It would be a real service to keep it updated--just with critical security updates alone.

New User

Re: I am running a Mac 10.5.8 and your software says it should be compatible with 10.5, yet it says it is incompatible with my operating system. Why?

Thanks! I agree with you completely. I love my computer, it does everything I need it to. I have no reason to upgrade to a whole new computer just because it has new bells and whistles, or is marginally faster than what I have. I'm not using it for gaming, and I don't mind waiting an extra second or 2 for internet pages to load.Firefox has been a wonderful program. it would be shame if they force us to switch to something that is not as good.

Support Forum Moderator

Re: I am running a Mac 10.5.8 and your software says it should be compatible with 10.5, yet it says it is incompatible with my operating system. Why?

I seriously doubt that Mozilla would even consider extending support for Firefox 3.6.x beyond April, the only reason it has been supported this long is because Mozilla hadn't properly considered the enterprise user-base when they came up with the Rapid Release scheme. EOL for 3.6.x coincides with the release of ESR 10.2 - ESR 10.0 & 10.1 are "QA" versions so enterprise users have 12 weeks to test before they roll out the new version.

IIRC, the original plan for EOL for 3.6..x was at the end of July 2011 when Firefox 6.0 was released. So 3.6.x users ended up getting almost 9 months more before EOL.

Have you tried TenFourFox support - http://tenfourfox.tenderapp.com/ - to discuss your issues with it?

To put a positive spin on Mozilla not directly supporting PPC Macs any longer, at least they make it possible for anyone to create a "Powered by Mozilla" web browser for older computers who aren't supported their maker or OS developer any longer and whose user base is no longer large enough for Mozilla to continue supporting it.

New User

Re: I am running a Mac 10.5.8 and your software says it should be compatible with 10.5, yet it says it is incompatible with my operating system. Why?

I haven't tried TenFourFox support, but I have tried a number of different versions of it. FX 3.6 is extremely stable and usable. TenFourFox is quite buggy, though I am impressed by the amount of effort involved. I am also conerned about third-party browser security issues.

It is true that Apple hasn't provided too much support for PowerPC lately, though we got an Itunes update about a month ago. On the other hand, Mozilla supports much older Windows computers than my 1.5 GHZ Powerbook. I realize that there are more Windows Users out there than Mac users, but there are still quite a lot of people with PowerPC computers.

I do understand that Mozilla has been better than everyone else for supporting older computers, and I appreciate it. I'd just like for them to continue to be better! We don't all have the $$$ to buy new laptops.