cancel
Showing results for 
Search instead for 
Did you mean: 

How do I install required plug-in jre-1_5_0_11-windows-i586.xpi

SOLVED
Highlighted
New Contributor

How do I install required plug-in jre-1_5_0_11-windows-i586.xpi

I'm trying to use Mozilla Firefox 3.6.15 with the Web Version of QPASA 4.0.0.80a, an MQSeries monitoring tool. When I point to the QPASA URL, I'm prompted to install a plugin. However, when I try to install it, Firefox looks for http://javadl-esd.sun.com/update/1.5.0/jre-1_5_0_11-windows-i586.xpi, but says it can't install it because the Install script was not found (-204).

When I google jre-1_5_0_11-windows-i586.xpi, I find it's actually located at http://java.sun.com/update/1.5.0/jre-1_5_0_11-windows-i586.xpi. However, even when I paste this location into the Firefox url window, Firefox STILL insists on looking for it in http://javadl-esd.sun.com/update/1.5.0/jre-1_5_0_11-windows-i586.xpi and fails.

How can I get Firefox to look for this file in the correct location?

1 ACCEPTED SOLUTION

Accepted Solutions
Support Forum Moderator

Re: How do I install required plug-in jre-1_5_0_11-windows-i586.xpi

That xpi package looks like an installer for Java 1.5.0-11, that is from 2006 - 5 years ago. You really don't want to install Java 1.5.0-11 because it won't work with Firefox 3.6+ versions, which need Java 1.6.0-12 or higher with the Second Generation Plugin.

The file I got from both of those URL's is the same (right-click the link and use Save Link As... so Firefox doesn't try to install it and fail - then open it with 7-Zip to examine the internal files). That XPI package is too old for recent versions of Firefox, it has an install.js file that was used by Firefox 1.5 and prior versions. Firefox 2.0 and newer use an install.rdf file.

2 REPLIES
Support Forum Moderator

Re: How do I install required plug-in jre-1_5_0_11-windows-i586.xpi

That xpi package looks like an installer for Java 1.5.0-11, that is from 2006 - 5 years ago. You really don't want to install Java 1.5.0-11 because it won't work with Firefox 3.6+ versions, which need Java 1.6.0-12 or higher with the Second Generation Plugin.

The file I got from both of those URL's is the same (right-click the link and use Save Link As... so Firefox doesn't try to install it and fail - then open it with 7-Zip to examine the internal files). That XPI package is too old for recent versions of Firefox, it has an install.js file that was used by Firefox 1.5 and prior versions. Firefox 2.0 and newer use an install.rdf file.

New Contributor

Re: How do I install required plug-in jre-1_5_0_11-windows-i586.xpi

Thanks. I was afraid of that. The web version of QPASA we have is at least as old as 2007. Since the web version of QPASA expects that plug-in version, there's probably no way it will work with the current Firefox version.

We intend to upgrade QPASA to the latest version, but haven't done so. I'll try Firefox again when the upgrade is complete.

Once again, thanks for your help.