cancel
Showing results for 
Search instead for 
Did you mean: 

How do I get Firefox to check addon compatibility first, then ask me if I want to continue the Firefox update?

SOLVED
Highlighted
New Contributor

How do I get Firefox to check addon compatibility first, then ask me if I want to continue the Firefox update?

How do I get Firefox to check add-on compatibility first, then ask me if I want to continue the Firefox update? The update process currently only tells me that an add-on has been disable after applying the Firefox update. The Options > Advanced > Update tab switch, "Warn me if this will disable any of my add-ons", does not seem to work.

1 ACCEPTED SOLUTION

Accepted Solutions
Support Forum Moderator

Re: How do I get Firefox to check addon compatibility first, then ask me if I want to continue the Firefox update?

delores51

Here is an add-on which does that.
https://addons.mozilla.org/en-US/firefox/addon/is-it-compatible/

Specifically, which add-ons are always showing up as incompatible after a Firefox update? As of Firefox 10, extensions which are properly made shouldn't pose a problem, with a few exceptions.

Extension which contains binary code have to be compiled for each new version of Firefox. Those add-ons typically are installed by security suite applications like Norton, McAfee, ZoneAlarm, etc.

8 REPLIES
Legendary Contributor

Re: How do I get Firefox to check addon compatibility first, then ask me if I want to continue the Firefox update?

Hello BigErnie, i see in your Additional System Details/More Information that you want Tab Mix Plus , see : Tab Mix Plus is incompatible with Firefox 17 - Use the development build as a workaround


thank you

New Contributor

Re: How do I get Firefox to check addon compatibility first, then ask me if I want to continue the Firefox update?

How do we check that new versions of FF are compatible with our existing Add-ons? I'm really quite over always having half of them not working after updating FF. It's very frustrating. Couldn't there be an option in the Add-ons menu that checks if they're compatible with a new version? Thanks.

Support Forum Moderator

Re: How do I get Firefox to check addon compatibility first, then ask me if I want to continue the Firefox update?

delores51

Here is an add-on which does that.
https://addons.mozilla.org/en-US/firefox/addon/is-it-compatible/

Specifically, which add-ons are always showing up as incompatible after a Firefox update? As of Firefox 10, extensions which are properly made shouldn't pose a problem, with a few exceptions.

Extension which contains binary code have to be compiled for each new version of Firefox. Those add-ons typically are installed by security suite applications like Norton, McAfee, ZoneAlarm, etc.

New Contributor

Re: How do I get Firefox to check addon compatibility first, then ask me if I want to continue the Firefox update?

Thanks for replying Ed. The last few times I updated FF about half the add-ons didn't work, so I ended up deleting them. The ones I remember not working then and which I now have are Net Usage Item, Image Toolbar and Australian Dictionary. There were others, but I've since lost them as I couldn't use them, which is why I've been reluctant to upgrade again. Cheers.

New Contributor

Re: How do I get Firefox to check addon compatibility first, then ask me if I want to continue the Firefox update?

Thanks ideato. I will definitely look into the Tab Mix Plus development build.

New Contributor

Re: How do I get Firefox to check addon compatibility first, then ask me if I want to continue the Firefox update?

I am also going to look into the "is-it-compatibile" add-on.

The funny thing is that, in the past, FireFox did check the add-ons before applying the updates.

Thanks Ed

Legendary Contributor

Re: How do I get Firefox to check addon compatibility first, then ask me if I want to continue the Firefox update?

Tab Mix Plus NEW version 0.4.0.3.1 is available and reportedly fixes the bugs that made it not compatible with Firefox 17 see : https://support.mozilla.org/en-US/forums/contributors/708781?last=49574#post-49572

thanks

New Contributor

Re: How do I get Firefox to check addon compatibility first, then ask me if I want to continue the Firefox update?

the only trouble with the suggested add-on which checks compatibility, is that it only seems to check whether things SAY they are compatible.

One of my favourite add-ons (Edit Bookmarks Plus 2.3.0) is said to be compatible, but as soon as I updated to Firefox 18 it stopped working properly.