cancel
Showing results for 
Search instead for 
Did you mean: 

Help. firefox 19.0 says norton toolbar 2013.2.4.2 is not compatible

SOLVED
Highlighted
New User

Help. firefox 19.0 says norton toolbar 2013.2.4.2 is not compatible

Upgraded to 19.0 and lost norton toolbar 2013.2.4.2. Ran liveupdate but 2013.2.4.2 is the latest version.

1 ACCEPTED SOLUTION

Accepted Solutions
Site Moderator

Re: Help. firefox 19.0 says norton toolbar 2013.2.4.2 is not compatible

the minor update from 19 to 19.0.2 shouldn't break compatibility for norton's extension. norton always releases updates to its toolbar the same time that new major firefox versions are released every six weeks - for details please refer to the link that james has already provided above.

13 REPLIES
Site Moderator

Re: Help. firefox 19.0 says norton toolbar 2013.2.4.2 is not compatible

I knew Firefox 19 was to release this week but did not think it had been released yet. It is not unusual for Norton Toolbars to break new releases of Firefox.

Disable the toolbar for now, it will not affect your AntiVirus, and Firefox itself by default has some phishng protection anyway.

Look at the Norton forums or this forum for news on updates.


I guess you must be on the Beta channel it appears fx 19 not yet released

Site Moderator

Re: Help. firefox 19.0 says norton toolbar 2013.2.4.2 is not compatible

There is no release folder yet for 19.0 as there is only the 19.0 beta 6 and 19.0 build1 Release Candidate test builds.

Norton only provides updates for Release builds though they have probably been using the 19.0 Beta's and the RC build to test their patches on to be ready for 19.0 final release on Tuesday.

The 2013.2.4.2 live update was for things like Firefox 18.0.2 release as per http://community.norton.com/t5/Norton-Toolbar-Norton-Identity/Firefox-18-Support-for-Norton-Toolbar/...

Site Moderator

Re: Help. firefox 19.0 says norton toolbar 2013.2.4.2 is not compatible

By the way Norton has a update to support Firefox 19.0 for a couple days now. http://community.norton.com/t5/Norton-Toolbar-Norton-Identity/Firefox-19-Support-for-Norton-Toolbar/...

New User

Re: Help. firefox 19.0 says norton toolbar 2013.2.4.2 is not compatible

Doing without Norton toolbar is not possibe for the tens (maybe hundreds) of thousands who use its ID Safe. I myself have nearly 200 username/password combinations and could not possibly remember all of them. Without the toolbar, and therefore without access to the Norton ID Safe (nowadays called "vault", originaly it was "password manager") I cannot even do critical things like pay bills. Does anyone know if Norton is compatible yet (March 9, 2013) with Ffx 19? Also, this happens EVERY time Firefox goes to a new release. With so many people using both Ffx and one of another of the norton products (NIS, 360, NSS, etc.), this is ludicrous. Firefox installs an update, which turns out to be a new release. Norton is incompatible and is disabled during the installation. You are forced to uninstall Ffx, find and download the earlier version (in this case now, Ffx18). IF you can find the older version, you then install it. Then you continually have to "x" out the constant "Critical Update For Firefox, Download Now" notices. And you MAY not have found the old version in the first place. In an apparent attempt to force everyone into the latest and greatest, Mozilla won't let you have them anymore (they used to), and none of the secondary download sites have them either. Search for, say "download Firefox 18" and most of the results will be for Ffx 19, and even with the results listings that actually do say Ffx 18, or any older version, when you go to the site you'll find that the only thing you can get is 19. I was just lucky that I had kept some old Ffx setup files, although I was forced to go all the way back to 17 because I seem to have somehow lost the one for 18. Mozilla either needs to provide easy access to at least 1 version back after releasing a new version or, better yet, get with Symantec/Norton and provide them with the new code and a firm release date early enough that they can have a patch ready in time for the new Ffx release. This problem has gone on for years now every single time a new Ffx is released and it is WAY past time that it was fixed. I absolutely MUST have acess to my passwords in Norton (eveything else in my Norton is turned off - I use ESET, which is about a thousand times better protection-wise) and as many years as I have used it, I DO NOT actually NEED Firefox. I am fed up with this nonsense and, with it getting harder and harder to even find an older version (thank you for that, Mozilla) I am very close to dumping Ffx and switching to Opera, Safari, Chrome or maybe even, God forbid, IE.

Site Moderator

Re: Help. firefox 19.0 says norton toolbar 2013.2.4.2 is not compatible

Firefox will have just updated to Fx19.0.2. As usual Norton utilities will likely break or break Firefox. Presumably Norton updates will not be made available in advance from Norton.

If you rely on proprietary Norton software, that is your choice but you will need to keep that updated.

The current Firefox release is itself a critical security update.

It is possible to use outdated old slow versions of Firefox, Firefox even explains how and where to get the downloads

In ordinary circumstances this is not recommended, it is extremely unwise. (Unless for instance you are using a virtual machine or only testing offline ) You will increase the risks to the computer and to your personal data, but you do have the choice and the right to make such a decision.

Site Moderator

Re: Help. firefox 19.0 says norton toolbar 2013.2.4.2 is not compatible

the minor update from 19 to 19.0.2 shouldn't break compatibility for norton's extension. norton always releases updates to its toolbar the same time that new major firefox versions are released every six weeks - for details please refer to the link that james has already provided above.

New User

Re: Help. firefox 19.0 says norton toolbar 2013.2.4.2 is not compatible

Actually, using Norton is NOT a choice. I NEED their ID Safe app. I have too many passwords to be able to remember them. Although that's ALL I need from them, I have everything else in their Norton Security System package turned off, I DO need that. If I could find somthing else that would work as well for the passwords, and into which I could easily transfer all the password data from Norton, I'd dump Norton altogether.As for the "old, slow" Ffx, all the way back to 3. something, it works fine for me. And when I follow Mozilla's instructions on how to get an older version, what I end up with is a text file, NOT a downlodable setup file. As for "critical security update" I've never had a security problem with any of the older ones. That may well be due to a combination of there being nothing about me, my computer, or my life that would make me a specific target fot hacking and my using ESET to keep junk out of my system. The problem is obviously that Mozila doesn't bother trying to coordinate with Symantic so that there could be a Norton compatibility update update ready in time for a new Ffx release. So far, the problem has mainly occured when Ffx goes to a new number, like from 17 point something to 18. It doesn't usually happen when the change is just from point whatever to point something else.

New User

Re: Help. firefox 19.0 says norton toolbar 2013.2.4.2 is not compatible

Thanks. Having dealt with this problem for years, I'm aware of that. But there is always a time gap between a new release of Firefox -meaning a change to a new number, not just an upgrade from say 17.1 to 17.2. As long as the release main number stays the same, there isn't usually a problem. But when the Ffx version changes completely, like from 18 to 19, it always happens, and the Norton update seems to never be available right away. The wait can be anywhere from a day or two to, literally, weeks. If Mozilla and Symantic would coordinate, the problem would go away, but that's apparently too much trouble for thrm to bother with.

Site Moderator

Re: Help. firefox 19.0 says norton toolbar 2013.2.4.2 is not compatible

in my experience through the last few updates norton has always provided an update on the same day a new firefox version was released (except for its security suite offspring for comcast which seems to have a lower priority). it just might take a few days until this is automatically distributed through their liveupdate system, so it's probably best to manually check for updates after a new firefox version has been installed.

firefox has a fixed release schedule - a new version is released every six weeks & the exact dates are published months in advance, so this certainly doesn't come as a surprise for any other software vendor...