cancel
Showing results for 
Search instead for 
Did you mean: 

Firefox doesn't start and I get this: “Error: Platform version ’18.0.1’ is not compatible with minVersion > = 18.0 maxVersion < 18.0

Highlighted
New Contributor

Firefox doesn't start and I get this: “Error: Platform version ’18.0.1’ is not compatible with minVersion > = 18.0 maxVersion < 18.0

Firefox worked and then when I shut down and restarted I suddenly started getting this message. What can I do?

Tags (2)
4 REPLIES
Site Moderator

Re: Firefox doesn't start and I get this: “Error: Platform version ’18.0.1’ is not compatible with minVersion > = 18.0 maxVersion < 18.0

hello, this error might be caused by security programs such as zone alarm - please temporarily disable those programs for the following procedure:

  • download the full firefox setup file from getfirefox.com
  • uninstall firefox on the machine (but don't chose to delete your custom files & settings in the uninstaller)
  • manually delete all remaining files in the firefox program folder, which usually resides in C:\Program Files (x86)\Mozilla Firefox\
  • reinstall firefox
Site Moderator

Re: Firefox doesn't start and I get this: “Error: Platform version ’18.0.1’ is not compatible with minVersion > = 18.0 maxVersion < 18.0

New Contributor

Re: Firefox doesn't start and I get this: “Error: Platform version ’18.0.1’ is not compatible with minVersion > = 18.0 maxVersion < 18.0

I have this error too, however it's on Linux, on CentOS 5.9. The OS repo currently has Firefox 17.0.3 on it and I want to run a separate copy of up-to-date Firefox in another directory and I got this error when I tried to run it:

[root@mymachine firefox]# ./firefox Error: Platform version '17.0.3' is not compatible with minVersion >= 19.0.2 maxVersion <= 19.0.2

I can't delete the original copy of Firefox nor do I want to. What would be my recourse in this instance?

Site Moderator

Re: Firefox doesn't start and I get this: “Error: Platform version ’18.0.1’ is not compatible with minVersion > = 18.0 maxVersion < 18.0

Such an error is always caused by inconsistent files in the Firefox program folder (application.ini and/or platform.ini and possibly others) and your only option is to reinstall that version of Firefox, either via the software repositories or the Mozilla server.

Be sure to delete all files in that folder before copying the files from that tar.bz2 archive.<

Note that the current ESR version is 10.0.5

All Firefox releases: