cancel
Showing results for 
Search instead for 
Did you mean: 

Firefox & Java [SOLVED]

Highlighted
New Contributor

Firefox & Java [SOLVED]

God it's been difficult getting somewhere actually to ask a question !!!!

When will Mozilla and Oracle fix the Java Problem?

If I update to FF v18 my Java will not work correctly with either Java 7U9 or the latest version - basically no sound, no mouse support.

Therefore I have downloaded FF v13 and installed it with Java 7U9 and it works. It's all I can do if I'm to use the Java-enabled sites I need. No point in prompting me to update, as the update just plain doesn't work!!

Everything worked in Internet Explorer with both Java 7U9 or the latest Java, so I can see myself migrating to IE or Chrome.

--

6 REPLIES
Site Moderator

Re: Firefox & Java [SOLVED]

Ok so by using such ancient versions of Firefox and Java your computer is now wide open with gaping security holes.

Please update to Firefox 18.0.1, then install Java 7 update 11. Then Reset Firefox, Refresh Firefox - reset add-ons and settings

New Contributor

Re: Firefox & Java [SOLVED]

The ancient version works, the latest doesn't even with Java U11. I have to use the add-on NoScript to give me some degree of protection, which is inconvenient to say the least.

If you don't believe me, go to http://websdr.ewi.utwente.nl:8901/ and see if you get sound. Can you move the inverted V type arrow/slider below the waterfall away from 15 MHz, I can't with FF 18 and any brand of Java. I can with IE and FF 13.

-- Jim.

Site Moderator

Re: Firefox & Java [SOLVED]

Works for me with Java 6U38 on Linux and Firefox 18.0.1.

There are several Java applets running, so make sure to click the icon on the location bar to activate them all.

New Contributor

Re: Firefox & Java [SOLVED]

>Works for me with Java 6U38 on Linux and Firefox 18.0.1. > > http://www.websdr.org/

But not for me seemingly. I assume 6U38 Linux=7U11 Windows.

>There are several Java applets running, so make sure to click the icon >on the location bar to activate them all.

Clicking on the icon in the location bar only tells me the website doesn't supply identity info and isn't encrypted !

If I put FF 18 on with Java SE 7 U11 I'm prompted to allow the applet to run; I do that but it doesn't run. 'Don't show this dialogue again' doesn't work either.

If I put FF 13 on with SE 7 U11 it all works, hence it would seem reasonable to assume the problem is with FF 18 on XP Home SP3. The same problem manifests itself on XP Pro SP-3; I haven't experimented with Windows 7 Pro 64-bit as yet but I imagine there will be problems there as well.

So I'm afraid I shall have to continue with FF 13 (or Internet Explorer) until light appears at the end of the tunnel, otherwise I shall be unable to use other peoples' receivers to listen to shortwave.

--

Jim.

Site Moderator

Re: Firefox & Java [SOLVED]

Works for me as well with Java 7U11 on Linux.

Is the Java plugin listed in "Tools > Add-ons > Plugins" and on the aboutSmiley Tonguelugins page?

Do you see an additional icon on the location bar to the left of the Site Identity Button to activate a blocked (Java) plugin?

New Contributor

Re: Firefox & Java [SOLVED]

>Is the Java plugin listed in "Tools > Add-ons > Plugins" and on the >aboutSmiley Tonguelugins page?

Yes.

>Do you see an additional icon on the location bar to the left of the Site Identity >Button to activate a blocked (Java) plugin?

I did eventually notice it !

To cut a long story short: I installed FF 18.0.1 and SE7 U13 and it works, but not as before. I now have to click up to three times on a dialogue box in FF for a Java site to run. I was also running the NoScript addon which was confusing the issue further. However, with NoScript disabled it does work despite the additional clicks.

Does this mean I can now dispense with NoScript ?

Many thanks for your time.

-- Geo