cancel
Showing results for 
Search instead for 
Did you mean: 

Firefox 7.0 incompatibility with ZoneAlarm

SOLVED
Highlighted
New User

Firefox 7.0 incompatibility with ZoneAlarm

I just received a notification that Firefox 7.0 is available.

When the installation starts, it gives a warning that: ZoneAlarm Security Engine 1.5.324.0 is incompatible and will be disabled if Firefox 7.0 is installed.

I imagine the consequences of continuing with the installation will disable ZoneAlarm.

When will this problem be overcome?

I won’t update Firefox if it disables my system security?

1 ACCEPTED SOLUTION

Accepted Solutions
Shooting Star

Re: Firefox 7.0 incompatibility with ZoneAlarm

It is the responsibility of third-party vendors to keep their products up-to-date. Firefox 7 has been in beta testing for 6 weeks, all vendors know where to find the beta versions and can, if they so choose, to test their products during that time.

Zone Alarm is notoriously late in updating their product. Some other security application vendors have already released updates for Firefox 7 compatibility for their toolbars.

I have been a Zone Alarm user for years, since the time that they only had a free firewall, but this may be my last year using the product. I do NOT use their toolbar, even though parts are installed when you tell the install program to not do so; I have disabled the remainder of the parts that they install into Firefox. If you physically remove those parts on your hard drive, the ZoneAlarm interface indicates an error with a "Fix It" button. CheckPoint spent an inordinate amount of time making their current interface "pretty", with only minor changes to functionality.

The decision to update or not update Firefox is the users.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

14 REPLIES
Shooting Star

Re: Firefox 7.0 incompatibility with ZoneAlarm

Only the toolbar is not compatible with Firefox because ZoneAlarm has not updated the toolbar. (NOTE: ZoneAlarm just started silently installing the toolbar update for Firefox 6 in the last couple of weeks; so they seem to be running about a month behind). You can post on the ZoneAlarm forum for confirmation about the toolbar, when it will be updated, etc. ZoneAlarm should still be working in the background to protect you.

Firefox has a feature similar to the main function of most security application toolbars to keep you away from malware and phishing sites. I do not use the toolbar that comes with my security application, but instead depend on Firefox's Safe Browsing component.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

New User

Re: Firefox 7.0 incompatibility with ZoneAlarm

I just chatted with Zone Alarm. This is the answer I received:

ZA Chat Reply:

At the moment we do not support any version of fire fox above version 5. However we are working on it.

Should I care if the zone alarm browser security is disabled?

You will have protection from the program but will not have any browser tools.

Okay, I guess I'll have to wait until you catch up.

Shooting Star

Re: Firefox 7.0 incompatibility with ZoneAlarm

Post on the Zone Alarm Forum and ask for

  • the location of the User Manual on the web so that you can read about the toolbar
  • also ask what the features of the toolbar are, what the features do, and any risks associated with not using the toolbar until they update the toolbar
  • Zone Alarm forum: http://forums.zonelabs.com/index.php

Their tech support is wrong about only being compatible through Firefox 5 according to this: http://forums.zonelabs.com/showthread.php?t=77781&highlight=firefox


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

New User

Re: Firefox 7.0 incompatibility with ZoneAlarm

Thanks for your reply Safebrowser,

I'm very familiar with zone alarm, and I'm familiar with the problem of applications being out of synchronization. I know the chat person was actually wrong, but I'm sure he gave me the official line.

I'm running an advanced release version of zone alarm and I have the a browser security update your link to the zone alarm forum mentions.

I've checked into it a little further, and there's more to the zone alarm browser security than the toolbar. it also handles download security checks and file scans.

I would not recommend disabling the zone alarm browser security!

Don't install Firefox 7.0 using the "check for updates," button on the Help>About Firefox window, because I believe it updates immediately.

Wait for Firefox to prompt saying that "an update is available," click on the update button, and wait for the screen showing what extensions/plug-ins Firefox finds incompatible. If it says the "Zone Alarm Browser Security," will be disabled, back out and click on the "Ask Me Later," button.

Firefox 7.0 has gotten a little ahead, or hasn't explored all the consequences of its interaction with other common applications.

Shooting Star

Re: Firefox 7.0 incompatibility with ZoneAlarm

It is the responsibility of third-party vendors to keep their products up-to-date. Firefox 7 has been in beta testing for 6 weeks, all vendors know where to find the beta versions and can, if they so choose, to test their products during that time.

Zone Alarm is notoriously late in updating their product. Some other security application vendors have already released updates for Firefox 7 compatibility for their toolbars.

I have been a Zone Alarm user for years, since the time that they only had a free firewall, but this may be my last year using the product. I do NOT use their toolbar, even though parts are installed when you tell the install program to not do so; I have disabled the remainder of the parts that they install into Firefox. If you physically remove those parts on your hard drive, the ZoneAlarm interface indicates an error with a "Fix It" button. CheckPoint spent an inordinate amount of time making their current interface "pretty", with only minor changes to functionality.

The decision to update or not update Firefox is the users.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Re: Firefox 7.0 incompatibility with ZoneAlarm

More pressure should be applied to Zone Alarm to update there products. When my Extreme subscription ends I will look around for another product!

Shooting Star

Re: Firefox 7.0 incompatibility with ZoneAlarm

tony_a20:

To help other users find solutions, please return and sign-in to the forum with your user name and password:

  • click on "Solved It" next to the reply ABOVE that BEST solved your question
  • DO NOT click "Solved It" next to this reply

Thanks

New User

Re: Firefox 7.0 incompatibility with ZoneAlarm

I have just downloaded FF this date. 7Mar,12 and as of this late date, Zone Alarm I am informed, is still disabled. Color me very confused. Have had ZA for many years with only a few glitches here and there, and so hate to give it up just because it might not work with FF. But I'd like to keep the Fox too. So what happens now?

New User

Re: Firefox 7.0 incompatibility with ZoneAlarm

I noticed I have one answer. Great. Now where do I look for it cos it isn't in my email. ???

Got and thank you very much