cancel
Showing results for 
Search instead for 
Did you mean: 

FF20 cannot read some unicodes

Highlighted
New Contributor

FF20 cannot read some unicodes

For example this website: https://www.feedsapi.org/index.php

Screenshot: http://take.ms/84IWc

7 REPLIES
Legendary Contributor

Re: FF20 cannot read some unicodes

Sorry the webiste and screenshot not working.

You can check the order of the installed Languages.

  • Firefox > Preferences > Content > Languages


Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Site Moderator

Re: FF20 cannot read some unicodes

Does the font work on this page?

You can check the gfx.downloadable_fonts.enabled pref on the about:config page.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.
New Contributor

Re: FF20 cannot read some unicodes

clearing cache and cookies didn't help Smiley Sad

New Contributor

Re: FF20 cannot read some unicodes

i can see all the font fine on the fontawesome page. I also checked the setting in the about:config. It's enabled.

It still didn't work with safe mode

Site Moderator

Re: FF20 cannot read some unicodes

The two sites use different locations for the CSS file that loads the font, so make sure that the file isn't blocked.

You can check the Net log in the "Web Developer > Web Console" (Ctrl+Shift+K) to see if the font-awesome.css file is loaded and the fontawesome-webfont.woff file as well.
You need to do a hard refresh (Ctrl+F5 or Ctrl+Shift+R) to bypass the cache.

See also:


Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

New Contributor

Re: FF20 cannot read some unicodes

Thanks for your reply.

Here is the error I got from the Web Console while the page is loading:

[17:36:40.746] downloadable font: download failed (font-family: "FontAwesome" style:normal weight:normal stretch:normal src index:1): bad URI or cross-site access not allowed source: https://commondatastorage.googleapis.com/feedsapivps/assets/css/font/fontawesome-webfont.woff @ https://commondatastorage.googleapis.com/feedsapivps/assets/css/font-awesome.css

So I guess that is why? But isn't it weird that I can see those icons fine on Chrome?

Site Moderator

Re: FF20 cannot read some unicodes

That is weird. I do not see anything in the HTTP response headers that would cause this.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.