cancel
Showing results for 
Search instead for 
Did you mean: 

FF gets really really slow when there are a lot inline images on a webpage

Highlighted
New User

FF gets really really slow when there are a lot inline images on a webpage

If webpage contains over 100 images as links that are inline:

for example:

<a href='IMG_1.jpg' rel="lightbox[galerii]" ><img src='.thumb_IMG_1.jpg'></a>
<a href='IMG_2.jpg' rel="lightbox[galerii]" ><img src='.thumb_IMG_2.jpg'></a>
...
<a href='IMG_n.jpg' rel="lightbox[galerii]" ><img src='.thumb_IMG_n.jpg'></a>

Then page loading takes unreasonably long time. Like 30-60 second or more. And thumbnails are really smaal, about 4k each - so theres not really much data or network traffic.

With 50 pics all is fine (loading time around a second); 90 pics also (loading time about a second); after 100 or so pictures on page you can see how FF struggles, first it displays some 20 images, then it 'thinks' then few more images, then it 'thinks' then few more images.. and so on.

Processor does not seem to get much load at that time.

When reloading the page with cached images, FF renders quickly - when forcing a shift reload, then it struggles again.

This is not a server problem as when tried with different browsers the problem does not occur on first page load or forced reload without cache. Only with FF this happens.

Also, when thumbnails are replaced with just text about image name as links the rendering is instant.

Tried safe mode with no addons - problem still accurs.

System has Phenom II X6 1055T processor with 8gigs of ram. FF cache has been placed on ramdrive for speed.

2 REPLIES
N/A

Re: FF gets really really slow when there are a lot inline images on a webpage

Hey,

can you please create a minimized test case or give me a URL of a testcase and then create a bug report or let me do that?

--Tobbi

New User

Re: FF gets really really slow when there are a lot inline images on a webpage

Thanx for your reply,

You can see the behaviour here: [http://grimsun.eu/gal/sdir.php] -- did not have time to make minimized example right now, so heres 'full' example.

Try it with different browsers, difference is immence.

By the way, test with FF under linux @ work showed a little better results but still not very good.

If you think or confirm that this is indeed problem with FF then it would be nice of you to raise a bugreport, yes.

Have a nice day Smiley Happy