cancel
Showing results for 
Search instead for 
Did you mean: 

Even tho I've downloaded FF7.0.1, both FF and Google tell me I have an old version of FF and I should upgrade!

SOLVED
Highlighted
New Contributor

Even tho I've downloaded FF7.0.1, both FF and Google tell me I have an old version of FF and I should upgrade!

Google won't let me on Google+ until I upgrade (which I have, twice), but more astonishing, FF insists I need to upgrade (claims I'm running 3.5.1!

1 ACCEPTED SOLUTION

Accepted Solutions
New Contributor

Re: Even tho I've downloaded FF7.0.1, both FF and Google tell me I have an old version of FF and I should upgrade!

That worked! Thanks for your help.

8 REPLIES
Support Forum Moderator

Re: Even tho I've downloaded FF7.0.1, both FF and Google tell me I have an old version of FF and I should upgrade!

New Contributor

Re: Even tho I've downloaded FF7.0.1, both FF and Google tell me I have an old version of FF and I should upgrade!

I inactivated all my add-ons. They are not the problem. But I don't want to mess with the user-agent. Any other ideas?

I can't believe Mozilla can't recognize it's own version of FF!!

Senior Contributor

Re: Even tho I've downloaded FF7.0.1, both FF and Google tell me I have an old version of FF and I should upgrade!

You can find the real Firefox version in the Help>About Firefox screen.
https://support.mozilla.com/en-US/kb/Finding%20your%20Firefox%20version
At this moment you are telling everyone that you have version 3.5.1, and that is what we recognize on this forum. We have no reason to assume that this is wrong.
Like the-edmeister said, it is possible that you useragent information is wrong and needs to be corrected.

New Contributor

Re: Even tho I've downloaded FF7.0.1, both FF and Google tell me I have an old version of FF and I should upgrade!

"About Firefox" on my computer verifies that I am using 7.0.1.

Support Forum Moderator

Re: Even tho I've downloaded FF7.0.1, both FF and Google tell me I have an old version of FF and I should upgrade!

Your Firefox UserAgent is messed up and is telling websites you visit that you are using Firefox 3.5.1.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

Reset the prefs related to the UserAgent as described in the article that I hyperlinked in my first answer.

New Contributor

Re: Even tho I've downloaded FF7.0.1, both FF and Google tell me I have an old version of FF and I should upgrade!

I tried to make the mods, but Reset for general.useragent.locale is greyed out. The other options for useragent, don't appear.

Support Forum Moderator

Re: Even tho I've downloaded FF7.0.1, both FF and Google tell me I have an old version of FF and I should upgrade!

Put this string - general.useragent. - in the Filter line at the top so you can see all the prefs related to the UA setting all at once. Reset any that are bold. Prefs that aren't displayed in a bold type are already at their default setting and don't need to be reset.

New Contributor

Re: Even tho I've downloaded FF7.0.1, both FF and Google tell me I have an old version of FF and I should upgrade!

That worked! Thanks for your help.