cancel
Showing results for 
Search instead for 
Did you mean: 

Error message Platform Version '14.0.1 is not compatible with minVersion >=15.0.1 maxVersion <=15.0.1

Highlighted
New Contributor

Error message Platform Version '14.0.1 is not compatible with minVersion >=15.0.1 maxVersion <=15.0.1

This error message comes up every time I try to open Firefox normally. I can only open Firefox in Administrator mode. Then when Firefox is open in Administrator mode I get this error message again when clicking on a link say in an email - the only way I can use the link is by copying the link and pasting it. I have tried uninstalling Firefox and installing it again. I have also tried resetting Firefox.

4 REPLIES
Site Moderator

Re: Error message Platform Version '14.0.1 is not compatible with minVersion >=15.0.1 maxVersion <=15.0.1

If you use ZoneAlarm Extreme Security then disable Virtualization and reinstall Firefox.
Other security software may have similar features to prevent Firefox from updating files properly.

See also:

New Contributor

Re: Error message Platform Version '14.0.1 is not compatible with minVersion >=15.0.1 maxVersion <=15.0.1

Thank you cor-el. Have done as suggested and I no longer get the error message. However now when I click on a link nothing happens unless I copy the link and paste as before. Any ideas?

New Contributor

Re: Error message Platform Version '14.0.1 is not compatible with minVersion >=15.0.1 maxVersion <=15.0.1

Hi cor-el Rebooted Firefox again and all working fine now!! Many thanks

Site Moderator

Re: Error message Platform Version '14.0.1 is not compatible with minVersion >=15.0.1 maxVersion <=15.0.1

You're welcome