cancel
Showing results for 
Search instead for 
Did you mean: 

Could not use firefox version >17.0 in Ubuntu 9.04

Highlighted
New Contributor

Could not use firefox version >17.0 in Ubuntu 9.04

I am using Ubuntu 9.04 Jaunty , i have installed firefox 17.0.1 manually , Now i want to update my firefox version in to higher one. When I checked the updates manually and automatically the firefox about screen always says its up-to-date. So i manually downloaded and tried to installed version 18.0.2 but its not working. Can any body help me to solve this Problem. Please don't say simply that i have to update my Linux Distro .

3 REPLIES
Site Moderator

Re: Could not use firefox version >17.0 in Ubuntu 9.04

If there are problems with updating then best is to download the full version of the Firefox installer.

Download a fresh Firefox copy and save the file to the desktop.

New Contributor

Re: Could not use firefox version >17.0 in Ubuntu 9.04

Dear Cor-el i tried Ur suggestion already. but its not working, when i just created symbolic links and opened it , nothing happend , firefox19 not opened

Site Moderator

Re: Could not use firefox version >17.0 in Ubuntu 9.04

Make sure that you meet the Firefox system requirements for Linux.