cancel
Showing results for 
Search instead for 
Did you mean: 

Caret not shown for designmode iframe which is empty

SOLVED
Highlighted
New Contributor

Caret not shown for designmode iframe which is empty

I am running into the problem described in https://bugzilla.mozilla.org/show_bug.cgi?id=308736 and can reproduce the problem using Firefox 19.0 for the two examples provided in the bug posting. The bug however is marked "Fixed" in a very old version of Firefox.

This is a case where we have an iframe and it is setup to be in designmode to act as a html editor. The editor starts off with no content (i.e. the <body> element contains no children). When the user clicks inside the iframe no caret appears. If the user types even one character the caret will then appear as expected. This however confuses users since after the initial click in the iframe they should be provided some sort of feedback to let them know that they can start typing.

1 ACCEPTED SOLUTION

Accepted Solutions
New Contributor

Re: Caret not shown for designmode iframe which is empty

I've opened a bug and the Mozilla developers have confirmed that this problem is a regression in Firefox 15 and later releases.

Original bugs: https://bugzilla.mozilla.org/show_bug.cgi?id=308736 – Caret is invisible when entering an empty designmode field https://bugzilla.mozilla.org/show_bug.cgi?id=395965 – Caret drawn vertically offset in designMode IFrame

Posting of regression in Firefox 15: https://bugzilla.mozilla.org/show_bug.cgi?id=846943 - Caret is invisible when entering an empty designmode field - regression

3 REPLIES
Support Forum Moderator

Re: Caret not shown for designmode iframe which is empty

You may get an answer here but probably stand a better chance on the Mozillazine fora or AMO. I am not even sure the test case and STR on the linked bug are still valid.

Try

New Contributor

Re: Caret not shown for designmode iframe which is empty

I've opened a bug and the Mozilla developers have confirmed that this problem is a regression in Firefox 15 and later releases.

Original bugs: https://bugzilla.mozilla.org/show_bug.cgi?id=308736 – Caret is invisible when entering an empty designmode field https://bugzilla.mozilla.org/show_bug.cgi?id=395965 – Caret drawn vertically offset in designMode IFrame

Posting of regression in Firefox 15: https://bugzilla.mozilla.org/show_bug.cgi?id=846943 - Caret is invisible when entering an empty designmode field - regression

Support Forum Moderator

Re: Caret not shown for designmode iframe which is empty

Well done.

Thanks for doing the research and posting back.