cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot comment or like on Facebook using older version of Firefox.

SOLVED
Highlighted
New User

Cannot comment or like on Facebook using older version of Firefox.

Whenever I try to Like something on facebook, nothing happens, and when I try to comment, if I write further than the small existing chatbar, it will not scroll to allow me to see what I'm typing. When I hit Enter to make the comment, nothing happens.

I'm concerned that Facebook simply won't work properly for me because of my old version of firefox (3.6.28), however I cannot upgrade to a newer version because of the age of my computer (running OSX 10.4.11), and I'm not in a position to get a new computer right now, so I'd like to see if I can find a fix.

I have already tried clearing my cookies and cache, I've checked my plugins for problematic ones, including "Effective Measure Community Plugin 3.1.0 (by Effective Measure Pty Ltd)" mentioned in another thread (it wasn't there) and disabled those it listed as being known to cause problems. I've checked to make sure my JavaScript is up to date and enabled. I've tried turning off all add-ons, and the possible combinations of some on, some off. I've tried adding a cookie permission for Facebook. So far, none of these fixes have been effective. I haven't been able to try troubleshooting in Safe Mode, because the option to run in Safe Mode is not listed under the Help dropdown menu.

Is there anything I haven't tried that anyone knows of for fixing the issue, or is my browser simply too outdated?

1 ACCEPTED SOLUTION

Accepted Solutions
SUMO Contributor

Re: Cannot comment or like on Facebook using older version of Firefox.

I don't know what versions of Firefox they test against at Facebook. It certainly is possible that some of the scripts have been updated so far that they have become incompatible. Might need to pose that question to Facebook.

First, though, you might test in a clean profile. This will bypass your accumulated customizations and extensions and give a truer answer to "is the problem version 3.6"? A new profile also will have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager as described in Managing profiles. Any time you want to switch between profiles, exit Firefox and return to this dialog.

Any difference in how FB works? If the issues are resolved in a clean profile, you might experiment with add-on settings and see whether that could be an issue.

7 REPLIES
SUMO Contributor

Re: Cannot comment or like on Facebook using older version of Firefox.

I don't know what versions of Firefox they test against at Facebook. It certainly is possible that some of the scripts have been updated so far that they have become incompatible. Might need to pose that question to Facebook.

First, though, you might test in a clean profile. This will bypass your accumulated customizations and extensions and give a truer answer to "is the problem version 3.6"? A new profile also will have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager as described in Managing profiles. Any time you want to switch between profiles, exit Firefox and return to this dialog.

Any difference in how FB works? If the issues are resolved in a clean profile, you might experiment with add-on settings and see whether that could be an issue.

Site Moderator

Re: Cannot comment or like on Facebook using older version of Firefox.

I believe this is a known issue as Camino 2.1.2 (based on same Firefox 3.6.28) users have this same issue. http://forums.mozillazine.org/viewtopic.php?f=12&t=2628899

If you can upgrade to OSX 10.5+ then you can use Firefox version up to 16.0.1 as 17.0 requires OSX 10.6+.

If your Mac as a PowerMac and not Intel, then there is the TenFourFox project to have newer Firefox.

New User

Re: Cannot comment or like on Facebook using older version of Firefox.

Thanks for your quick replies.

jscher2000:

I tried starting up the profile manager as per the help page's instructions, but unfortunately I only got the following message in Terminal:

dyld: Symbol not found: ___stack_chk_guard

 Referenced from: /Applications/Firefox.app/Contents/MacOS/firefox-bin
 Expected in: /usr/lib/libSystem.B.dylib

Instead of having the Profile manager open, even after restarting the computer.

James:

If this issue is widespread, then it may just be that a small change somewhere is causing the issue. If FB staff is aware of it, as mentioned in that forum, then it may just be something I'll have to wait and see on.

New User

Re: Cannot comment or like on Facebook using older version of Firefox.

Same problem here, plus a "You're using an old version of Firefox that is no longer supported" when opening facebook. Yeah, right, 3.6.28 is no longer supported because its number is too small, huh? How about Firefox 11 which was released on March 2012, i.e, at the SAME time? I wonder if the 68% of Firefox users who are using Firefox 16 are getting the same message, because Firefox 16 is no longer supported by Mozilla.

Looks like it was too hard for Facebook programmers to leave the working line of code alone. Someone needs to write a greasemonkey script that repairs what Facebook has scrapped.

New User

Re: Cannot comment or like on Facebook using older version of Firefox.

Oh well, looks like they changed it back... for now. Everything is working again, including likes, comments, and statuses.

New User

Re: Cannot comment or like on Facebook using older version of Firefox.

Yep, it seems they've got it all righted now.

Site Moderator

Re: Cannot comment or like on Facebook using older version of Firefox.

LeDechaine Firefox 3.6 was made officially EOL (End Of Life) on April 24 after about 27 1/2 months. There are no more security updates for the old Firefox 3.6 as the 3.6.28 was the last.

It originally came close to being EOL back about Firefox 3.6.19 last year (July 2011) but it then became the reluctant older supported version after Firefox 4.0 was released and then continued to get security updates until 3.6.28.

Also there are differences in what 3.6 and say 10.0 supported for example.