cancel
Showing results for 
Search instead for 
Did you mean: 

Can't update-says system does't meet requirement to run firefox

SOLVED
Highlighted
New User

Can't update-says system does't meet requirement to run firefox

I'm using Mac os X 10.5.8

1 ACCEPTED SOLUTION

Accepted Solutions
Site Moderator

Re: Can't update-says system does't meet requirement to run firefox

If you can update to OSX 10.6 (can be cheap) then that is a good option also.

4 REPLIES
Site Moderator

Re: Can't update-says system does't meet requirement to run firefox

Site Moderator

Re: Can't update-says system does't meet requirement to run firefox

Current Firefox versions need OS X 10.6 or later.

Firefox 16.0.2 is the last version that works on an Intel Mac with the OS X 10.5 operating system.

Another option to consider is to install the last Firefox 10.0.x ESR version as that version is more recent than the Firefox 16.0.2 version.

Firefox 17.0.x ESR has replaced the Firefox 10 ESR version, so you don't update.

Site Moderator

Re: Can't update-says system does't meet requirement to run firefox

If you can update to OSX 10.6 (can be cheap) then that is a good option also.

New User

Re: Can't update-says system does't meet requirement to run firefox

I am running OS 10.8.4 with an Intel Core i3. This is really too old? Also FF 23.0.1