cancel
Showing results for 
Search instead for 
Did you mean: 

Block Potentially Unsafe Components pop up from java in newer firefox versions

Highlighted
New Contributor

Block Potentially Unsafe Components pop up from java in newer firefox versions

I'm trying to use a web based java application, but newer firefox versions dont let me open it, this doesnt happen with 3.6 or lower What happens is that with newer versions says that I need a plugin to show the content (like when I dont have flash installed), but with 3.6 and below it displays an alert that prompts me to "Block Potentially Unsafe Components", after I press "No" it shows me the content

1 REPLY
Site Moderator

Re: Block Potentially Unsafe Components pop up from java in newer firefox versions

Hello,

Starting in Firefox 24, all versions of the Java plugin are "Click to Play" blocked, meaning that you have to click to activate Java for each site. See the How to allow Java on trusted sites article for more information.

When you see the "Activate Java" message box, simply click it to load the Java content normally.

Fx24-JavaActivate

If there is no visible area to activate Java content in the page, click the red plugin icon in the address bar. In the message panel that opens, choose "Allow Now" to enable Java content temporarily.

Fx24-JavaAllowNow

The next time you visit the site or any other that uses Java you will see this message again.

If you want to always activate Java for a particular site, you can use the "Allow and Remember" option shown above.

Does this solve your problem? Let us know.