cancel
Showing results for 
Search instead for 
Did you mean: 

BBC iplayer says "You need to upgrade Flash to version 10.1.0 or higher but I am on latest version

SOLVED
Highlighted
New User

BBC iplayer says "You need to upgrade Flash to version 10.1.0 or higher but I am on latest version

BBC iplayer says "You need to upgrade Flash to version 10.1.0 or higher to play Hearing the Past. Upgrade the Flash player now" I have version 10.3.183.7 I am on Firefox 3.6.22 on Fedora 14.

1 ACCEPTED SOLUTION

Accepted Solutions
New User

Re: BBC iplayer says "You need to upgrade Flash to version 10.1.0 or higher but I am on latest version

where can l find Flash to version 10.1.0

6 REPLIES
SUMO Contributor

Re: BBC iplayer says "You need to upgrade Flash to version 10.1.0 or higher but I am on latest version

Do you use the NoScript add-on to filter site scripts? In that case, a web site may assume there is a Flash problem when in fact the problem is that the script didn't run. Because large web sites often host media files on a content distribution network, you will need to check the NoScript popup for the one related to videos.

Site Moderator

Re: BBC iplayer says "You need to upgrade Flash to version 10.1.0 or higher but I am on latest version

Your above posted system details show an outdated Flash 10.0 r32 plugin, so it appears that Firefox doesn't find that 10.3.183.7 version.

  • Shockwave Flash 10.0 r32
New User

Re: BBC iplayer says "You need to upgrade Flash to version 10.1.0 or higher but I am on latest version

That was it, I'd not updated Flash in all locations, thanks.

Site Moderator

Re: BBC iplayer says "You need to upgrade Flash to version 10.1.0 or higher but I am on latest version

You're welcome

New User

Re: BBC iplayer says "You need to upgrade Flash to version 10.1.0 or higher but I am on latest version

where can l find Flash to version 10.1.0

New User

Re: BBC iplayer says "You need to upgrade Flash to version 10.1.0 or higher but I am on latest version

The answer was that Flash was installed in more than one location, when I found that out I was able to update the other locations and all was well. Thanks for your help.