cancel
Showing results for 
Search instead for 
Did you mean: 

After updating to v. 24.0 (and restarting) ALL add-ons (regardless whether they work or not) are marked "(disabled)", and clicking Enable button does nothing

SOLVED
Highlighted
New Contributor

After updating to v. 24.0 (and restarting) ALL add-ons (regardless whether they work or not) are marked "(disabled)", and clicking Enable button does nothing

After updating to v. 24.0 (and restarting, several times) ALL add-ons (regardless whether they work or not) are marked "(disabled)". I tried clicking "Enable" button for each add-on and nothing happened. There is only one add-on which is marked as incompatible with this version (but it was also incompatible with previous version, and so marked). Clicking "Update Add-ons", gives a short list of add-ons but "Install Updates" button is pale and doesn't work. I can only sort list by name or last update. Also, I disabled Ask Toolbar and that went well. When I click "Enable" button (button works ONLY for this add-on) it takes forever to get note: “Ask Toolbar will be enabled after you restart Firefox”, I used to get this info in seconds time before this update. (I do not really want Ask Toolbar, I just used it to see whether if I disable and then enable an add-on might do the trick.) Bottom line – I can not tell if add-on works (i.e. if it is enabled or disabled) unless I try using it. Even when I posted this question and installed Troubleshooter, it's also marked as "(disabled)"

1 ACCEPTED SOLUTION

Accepted Solutions
New Contributor

Re: After updating to v. 24.0 (and restarting) ALL add-ons (regardless whether they work or not) are marked "(disabled)", and clicking Enable button does nothing

Thanks a lot! I didn’t get a chance to try last cor-el’s suggestion (first I was away, than to busy). Couple days ago I turned browser on and found my problem had magically disappeared!

2013-09-19-11-35-48-3ead30.png 2013-09-19-11-35-28-cf81bc.png
5 REPLIES
All Star Contributor

Re: After updating to v. 24.0 (and restarting) ALL add-ons (regardless whether they work or not) are marked "(disabled)", and clicking Enable button does nothing

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

All Star Contributor

Re: After updating to v. 24.0 (and restarting) ALL add-ons (regardless whether they work or not) are marked "(disabled)", and clicking Enable button does nothing

Your question details indicate that most add-ons are enabled.

Site Moderator

Re: After updating to v. 24.0 (and restarting) ALL add-ons (regardless whether they work or not) are marked "(disabled)", and clicking Enable button does nothing

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end side of the Search Bar to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.sqlite file.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
New Contributor

Re: After updating to v. 24.0 (and restarting) ALL add-ons (regardless whether they work or not) are marked "(disabled)", and clicking Enable button does nothing

Thanks a lot! I didn’t get a chance to try last cor-el’s suggestion (first I was away, than to busy). Couple days ago I turned browser on and found my problem had magically disappeared!

2013-09-19-11-35-48-3ead30.png 2013-09-19-11-35-28-cf81bc.png
Site Moderator

Re: After updating to v. 24.0 (and restarting) ALL add-ons (regardless whether they work or not) are marked "(disabled)", and clicking Enable button does nothing

You're welcome

Are this screenshots from an extension window because the built-in about:addons page looks different?