cancel
Showing results for 
Search instead for 
Did you mean: 

Add-ons Manager

Highlighted
New Contributor

Add-ons Manager

I have Windows Vista and Adobe Reader X (10.1.6)

In Add-ons Manager:

Adobe Acrobat Adobe PDF Plug-In For Firefox and Netscape 10.1.6 Outdated Version

Where is the new version?

http://get.adobe.com/reader/ (Adobe Reader X (10.1.4)

Something strange, it isn't ?

5 REPLIES
Legendary Contributor

Re: Add-ons Manager

Hello valterj,

Something strange, it isn't ? ...... yes it is.

if you want to upgrade go from : ftp://ftp.adobe.com/pub/adobe/reader/win/11.x/11.0.02/


thank you

Site Moderator

Re: Add-ons Manager

Adobe Reader 11 wont run properly (though in some cases you may be able to install it) on Vista (Adobe dropped it from support for some reason). Reader 10 is the highest you can update to. However, you can use the built in firefox PDF reader, which will receive updates and remain secure as long as Firefox support vista (a long time)

Site Moderator

Re: Add-ons Manager

The Adobe Reader 10.1.4 is the latest full version that is offered for the Windows Vista platform.

You can only get the latest 10.1.6 version by updating the Adobe Reader, so if you have 10.1.6 then you can ignore the plugin check page.

New Contributor

Re: Add-ons Manager

Now I have 2 problems:

Shockwave for Director Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122 Outdated Version

Adobe Acrobat Adobe PDF Plug-In For Firefox and Netscape 10.1.6 Outdated Version

I Have Windows Vista! Please tell mozilla guys to solve these problems with plugins update!

New Contributor

Re: Add-ons Manager

I have Adobe Reader X 10.1.7 simply from updating it on my own and my platform is Vista. I have no idea why Mozilla keeps telling me to update the Plug-in and then shoots me over to a Reader 10.1.4 download.

I do have Acrobat X which I bought when it came out, and maybe that has something to do with it. In any case, clicking on the Firefox "update" box for the Adobe plug-in is logically incorrect, because you should at least be sent to a download for Adobe Reader 10.1.7, not 10.1.4.