cancel
Showing results for 
Search instead for 
Did you mean: 

why don't you all build firefox for android versions earlier than 2.2. My android device has android version 2.1 eclair.

SOLVED
Highlighted

why don't you all build firefox for android versions earlier than 2.2. My android device has android version 2.1 eclair.

My device has Android version 2.1 (eclair). Unfortunately there's no update available for my device, even in future. I would consider you as a top developer if you could optimize your browser to support my mobile device. And I know you won't, because as a developer it's very difficult to work on older versions of android, and who has got time for that. Really, I made a worst choice in selecting my mobile handset.

1 ACCEPTED SOLUTION

Accepted Solutions
Site Moderator

Re: why don't you all build firefox for android versions earlier than 2.2. My android device has android version 2.1 eclair.

It is due to technical reasons. Firefox for Android requires a feature called OpenGL ES. Open GL ES is used to draw to the screen. Android 2.2 is the first version of Android to support OpenGL ES 2.0 for NDK applications.

The first bullet point at https://en.wikipedia.org/wiki/OpenGL_ES#OpenGL.C2.A0ES.C2.A02.0_2

3 REPLIES
Site Moderator

Re: why don't you all build firefox for android versions earlier than 2.2. My android device has android version 2.1 eclair.

Android 2.1 isnt currently supported, and i dont know of any plans to support it.

Site Moderator

Re: why don't you all build firefox for android versions earlier than 2.2. My android device has android version 2.1 eclair.

It is due to technical reasons. Firefox for Android requires a feature called OpenGL ES. Open GL ES is used to draw to the screen. Android 2.2 is the first version of Android to support OpenGL ES 2.0 for NDK applications.

The first bullet point at https://en.wikipedia.org/wiki/OpenGL_ES#OpenGL.C2.A0ES.C2.A02.0_2

New User

Re: why don't you all build firefox for android versions earlier than 2.2. My android device has android version 2.1 eclair.

This information doesn't look very fair once, for NDK applications, OpenGL is supported from: OpenGL ES 1.1 Android 1.6 (API Level 4) and higher OpenGL ES 2.0 Android 2.0 (API Level 5) and higher

http://developer.android.com/tools/sdk/ndk/index.html#Reqs