cancel
Showing results for 
Search instead for 
Did you mean: 

package invalid

SOLVED
Highlighted
New User

package invalid

Hi thanks in advance for help. Motorola RAZR I (XT890) Android 4.0.4 No modifications Tried download from google play and mozilla site on each time get downloading then a package invalid error. Says app compatible with my t-mobile XT890


Any suggestion?

1 ACCEPTED SOLUTION

Accepted Solutions
Site Moderator

Re: package invalid

The Motorola Razr I is a Intel based phone. Firefox for Android only currently works with ARM based phones.

We are working on making Firefox for Android to work with Intel Android phones. Currently you can download a development version called Nightly at http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-x86/

9 REPLIES

Re: package invalid

Fix the '“Package File is Invalid”'

  • Make sure Android Automatic Restore is turned off (Settings -> Privacy)
  • Go to “Settings -> Applications -> Manage Applications
  • Tap to show “All” Applications
  • Scroll down to the Market App and tap it
  • Tap “Clear Cache” and “Clear Data”
  • Click “Uninstall Updates”
  • Exit everything and reboot your device
  • Your Error should now be fixed
New User

Re: package invalid

Thanks for help

have Settings > Apps then 3 tabs Downloaded Running All

in All do you mean Market Feedback Agent

Thanks in advance

New User

Re: package invalid

or do you mean Google Play Store

Re: package invalid

Ya... Its Google Play Store & Services

Site Moderator

Re: package invalid

The Motorola Razr I is a Intel based phone. Firefox for Android only currently works with ARM based phones.

We are working on making Firefox for Android to work with Intel Android phones. Currently you can download a development version called Nightly at http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-x86/

Site Moderator

Re: package invalid

vladimierhm, where does it say this app is compatible with the t-mobile XT890 ?

The Motorola RAZR phones it is compatible with have ARMv7 cpu's as your phone has a Intel Atom Z2480 cpu.

New User

Re: package invalid

Thanks to all Will wait for development of intel compatible firefox

James: both on phone and laptop searched for firefox browser for android https://play.google.com/store/apps/details?id=org.mozilla.firefox (if sign into google account a green box saying compatible with T-mobile XT890 appears just below install button (sorry cant get screenshot)

New User

Re: package invalid

Hi - it's been some time since this thread was updated. I see the nightly builds are still going (latest 9 June) but I'd rather wait for at least a beta release. Can you give us an update on progress and how close you are to a beta / full release for the Motorola Razr i (XT890)? Many thanks, Richard

Site Moderator

Re: package invalid

The current beta in the Play Store will install on x86 devices. https://play.google.com/store/apps/details?id=org.mozilla.firefox_beta