cancel
Showing results for 
Search instead for 
Did you mean: 

Does STARTTLS work in v1.1?

Highlighted
New User

Does STARTTLS work in v1.1?

From the discussion in bug 847032 and 914520, I understand that STARTTLS should work since end of September 2013. My ZTE Open from Movistar Spain is updated to v1.1 (build id 20130926115300). Using the email app (manual setup, stmp port 587) with a web.de email account fails with the following error message:

Unable to establish a connection with "smtp.web.de". There may be a problem with the network. [unresponsive-server]

Is there any way to make the app work with my email provider? Wait for a new update?

Thank you.

Tags (1)
14 REPLIES
Site Moderator

Re: Does STARTTLS work in v1.1?

New User

Re: Does STARTTLS work in v1.1?

@feer56: Thanks for answering so quickly. Unfortunately it doesn't really help, as the error message is different. And according to the discussion in bug 914520, the email app works with my email provider (web.de). I wonder if I am using wrong settings or a too old build?

Thank you

New User

Re: Does STARTTLS work in v1.1?

I read https://support.mozilla.org/en-US/que.../975957 again and realized that there was actually usefull information regarding my question in there:

the author writes that he can select IMAP+STARTTLS in the email app of Alcatel One Touch Fire v1.1. This option is not available in the ZTE Open (Spain) v1.1, where you can only select IMAP+SMTP or ActiveSync.

So obviously v1.1 is not equal v1.1 and the OS functionality is manufacturer dependent. Can anyone confirm this? And does anyone know the Build ID of the Alcatel One Touch Fire (Congstar) v1.1?

Thank you

New User

Re: Does STARTTLS work in v1.1?

I'm having the same issue with Keon v.1.1. It's possible to choose IMAP+SMTP and when entering data for SMTP both STARTTLS and SSL are available, but STARTTLS does not work (unresponsive server). When I choose SSL instead I can at least set up the mail account and receive mails. Sending is not possible since my provider does not use SSL. So you seem to be right about manufacturer dependency.

Regular User

Re: Does STARTTLS work in v1.1?

"unresponsive server" might happen, because the provider uses a different port than the one specified in the configuration. Maybe worth a try to check with the provider.

I got this error first, too. Once I had selected the right port, I got the bad security error message due to the lack of support for self-signed certificates with STARTTLS required by my mail-provider. I don't know, if the manual port selection is possible in all SW-versions discussed here.

New User

Re: Does STARTTLS work in v1.1?

Yes, manual port selection is possible.

I checked the ports with the provider again and he explicitly tells me to use 587. The same setting works fine with thunderbird, too. So that shouldn't be the problem.

New User

Re: Does STARTTLS work in v1.1?

My provider says SMTP with STARTTLS on port 587, no other option.

But that is not supported on ZTE Open v1.1 (Spain, Movistar): there is no SSL or STARTTLS option to chose from (which means only SSL is available, according to the development history). If I manually set the port to 587 anyway, I got the "unresponsive server" message. My provider does not use self signed certificates.

On the other hand, the IMAP server does not make any problems (as it runs with SSL on port 993). But I am still not able to receive my email, because as the STMP server does not configure, the account set up is aborted. So right now, I am doomed to read my email over the providers mobile web page.

Good to know that in the Keon v1.1, the STARTTLS option is given for the SMTP server (although it doesn't seem to work). But at least you are somehow able to receive your email.

Go_orange, may I ask which build ID your FFOS version has, if this info is available on your device?

And additional question: in FFOS v1.1 (whatever that means, as every device has different functionalities), push notification support has been introduced. Do you get a notification when you get a new email?

Cheers

New User

Re: Does STARTTLS work in v1.1?

My build ID is 20131107042952. And push notification doesn't work.

Well... I'll accept it and wait for a stable 1.2

New User

Re: Does STARTTLS work in v1.1?

Oh wow, 2013-11-07. And STARTTLS still does not work? I wonder if we should inform the developers then, as according to bugs 847032 and 914520 , these issues are resolved fixed. Which would mean that v1.2 won't change anything then. Or are these only fixed for v1.2 and not v1.1? I don't really understand the update rules. Anyone?

And yes, I accept it too that there are still bugs: when I bought the device, I knew that the OS is still in heavy developement . More features are welcome, but the only one that I can think of that I am really missing for my daily use is email with notification. And if I can help having it earlier by giving feedback, I will do so. Smiley Happy