cancel
Showing results for 
Search instead for 
Did you mean: 

In YOUTUBE videos are not playing

Highlighted

In YOUTUBE videos are not playing

I have recently upgraded my browser from Firefox 3.6 to Firefox 4 beta version. Now I find that videos are not playing in YOUTUBE website. A black window appears.

5 REPLIES
New User

Re: In YOUTUBE videos are not playing

Try to install Adobe Flash Again. If this doesn't works, check in you addons manager there isn't any plugin interfering with flash animations/videos

Site Moderator

Re: In YOUTUBE videos are not playing

That Firefox 4 beta 9 version is outdated.
Make sure that you update to the latest Firefox 4 RC2 version.


Clear the cache and the cookies from sites that cause problems.

  • "Clear the Cache": Firefox > Preferences > Advanced > Network > Offline Storage (Cache): "Clear Now"
  • "Remove the Cookies" from sites causing problems: Firefox > Preferences > Privacy > Cookies: "Show Cookies"

You can also try to change the protocol in the YouTube links from http: to a secure https:

New User

Re: In YOUTUBE videos are not playing

1. START any youtube video that's not working. 2. right-click on face of video. 3. click SETTINGS. 4. UNCHECK "Hardware Acceleration"

New User

Re: In YOUTUBE videos are not playing

I was having this problem and solved it by going into the Add-ons area, clicking on the Plugins menu item and disabling Shockwave Flash 11.3.300.257. Maybe that will help.

New User

Re: In YOUTUBE videos are not playing

Shokweave is disabled by me now videos are playing but speedbit video download is now not working