cancel
Showing results for 
Search instead for 
Did you mean: 

Firefox 4 won't start on Mac OS X 10.4.11.

Highlighted
New User

Firefox 4 won't start on Mac OS X 10.4.11.

I get an error message from Firefox 4, saying it won't run on this level of operating system.

CPU 2 GHz Intel Core 2 Duo.

I had to go back to 3.16

3 REPLIES
Support Forum Moderator

Re: Firefox 4 won't start on Mac OS X 10.4.11.

Firefox 4 requires at least OS X 10.5

New User

Re: Firefox 4 won't start on Mac OS X 10.4.11.

I attempted to download Firefox 4 because Firefox said it was compatible with Mac OS 4. I have OS 10.4.11. In attempting to download the downloader stated that I had a higher level of Firefox in applications and was attempting to download a lowever version. It asked if I wanted to do that or cancel so I canceled. Why does Firefox say that version 4 is compaitble with OS 4 when it obviously is not. Or should I have downloaded the newer version I thought I was downloading even though Firefox said I was downloading a version older than 3.6.17. The whole experience is very confusing and probably wrong. What's the right answer?

Site Moderator

Re: Firefox 4 won't start on Mac OS X 10.4.11.

Firefox 4 requires at least OS X 10.5 and an Intel Mac.

For an unofficial Firefox 4 compatible version that runs on Mac OS X 10.4.11 or Mac OS X 10.5.8 (PowerPC) you can look at:

Firefox 3.6.x (Mac OS X 10.4 and later) can be found here: