Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fire Fox Will not ask again to remember Passswords if you do not say yes the first time, remember option unchecks on restart.

  • 11 majibu
  • 3 wana tatizo hili
  • 8 views
  • Last reply by Al6286

more options

If you go to a secure website, and it needs a password, if you don't check remember password the first time say you forget or you just don't have time to do it right away Firefox never asks again for that site. This is also true for not this time option. Also the "remember password for sites" option under Tools/Options/General unchecks itself when you close Firefox and open it up again. Also there seems to be some sites that it NEVER asks to remember the password for. (But offhand I can't recall any at the moment.)

If you go to a secure website, and it needs a password, if you don't check remember password the first time say you forget or you just don't have time to do it right away Firefox never asks again for that site. This is also true for not this time option. Also the "remember password for sites" option under Tools/Options/General unchecks itself when you close Firefox and open it up again. Also there seems to be some sites that it NEVER asks to remember the password for. (But offhand I can't recall any at the moment.)

All Replies (11)

more options

There are some sites that draw the login form after the page load, and that blocks Firefox's password saving feature. Websites also can mark their forms for no auto-completion, which also blocks saving passwords. There are some workarounds, but let me return to the main question.

Firefox may have recorded that you never want to save passwords for that site. To clear this, you can use the site permissions page:

(1) In a new tab, type or paste about:permissions in the address bar and press Enter. This should load a long list of sites on the left, and several buttons to the right.

(2) Put part of the site's address in the search box at the upper left to filter down to the site you want.

(3) On the right side, adjust the "Store Passwords" setting for that site.

Does that let you save the login?

more options

Well I did go back a look at this. The page is informative but it still does not change the setting for pages that do not ask or if you say not now never ask again.

There is a manage password tab for those that work, perhaps for those that DON'T have a password set the tab should be ADD PASSWORD.

Al

more options

I didn't explain that very well. Try changing Block to Allow, then visit the site again to get the prompt to save the password. Does that work?

more options

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.
more options

There was no problem with your explanation. I understood it. It did not change much. One good example of a site that is not working is eBay. Strange PayPal is OK but eBay does not save.

more options

I did not see this helping much. Though when I was opening a closing Firefox it seems that the remember password option kept unchecking itself.

more options

Whoops! Let me change this eBay is OK but PayPal does not save passwords. Had it reversed. Was going by memory which maybe is not a sharp as it used to be. Sorry for the confusion. For some sites that don't save there is a "remember me" option that fills in my user name or email address but that is because it is remember my from the cookies on my computer. If I clear those I don't see that "remember me".

more options

PayPal uses autocomplete=off on the password field to prevent Firefox from saving and filling the name and password.
So you will have to remove autocomplete=off with a bookmarklet to make Firefox save the name and password on the PayPal website.

more options

Well sorry either it didn't work or I'm not using it correctly. Seem like this is what the about permissions tab does but for all sites. Right?

more options

No, this has nothing to do with permissions.

This is about websites disabling saving form data by specifying an autocomplete=off attribute.


Create a new bookmark (name: Remember Password) on the Bookmarks Toolbar via the right-click context menu or in the Library and paste the JavaScript bookmarklet code including the javascript: label in its location field.

You need to use the "Remember Password" bookmarklet before or after filling the name and password field on the website with the login form, but before submitting the login form by clicking a button on the web page.

If the site is using autocomplete="off" then you see a number not equal to 0 (i.e. attributes were removed) in the pop-up alert from the bookmarklet and Firefox should offer to remember the name and password via a drop down dialog of the key icon that will appear on the location bar.

more options

OK, now I got it. Yes it worked for a couple of sites that did not save the password. As I go the others I'll try it out there to thanks.