Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

On certain domain, firefox stop loading the page for a while

  • 6 majibu
  • 1 ana tatizo hili
  • 16 views
  • Last reply by cor-el

more options

This bug occurs very randomly, but it seems there have few things in common.

- Occurring on domain level, one domain at once. For example, if Youtube.com stuck, any sub address including each video page is not loaded. Other website and whole browser works fine. - Other program on same PC is not affected, too. - Which page is stop loading is completely random. It might be happen only on a popular, feature-rich site like amazon, google, but not sure. - The timing is also random. Maybe after waking PC up from sleep, but not sure. Frequency of occurrence is once every 1~5 days. - The workaround without restarting browser is 1.)switching to other container tabs(strangely), 2.)opening website on private window. Disabling all the addon manually didn't help.

Since it's randomness, I didn't have any logs about this issue.

This bug occurs very randomly, but it seems there have few things in common. - Occurring on domain level, one domain at once. For example, if Youtube.com stuck, any sub address including each video page is not loaded. Other website and whole browser works fine. - Other program on same PC is not affected, too. - Which page is stop loading is completely random. It might be happen only on a popular, feature-rich site like amazon, google, but not sure. - The timing is also random. Maybe after waking PC up from sleep, but not sure. Frequency of occurrence is once every 1~5 days. - The workaround without restarting browser is 1.)switching to other container tabs(strangely), 2.)opening website on private window. Disabling all the addon manually didn't help. Since it's randomness, I didn't have any logs about this issue.

Modified by bleepblopp

Chosen solution

This could also be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data = false on the about:config page to disable this feature until this is fixed by Google or Mozilla to see if that helps.

See also:


You can open the about:config page via the location/address bar. If you get the warning page, you can click the "Accept the Risk and Continue" button.

Read this answer in context 👍 1

All Replies (6)

more options

Did you disable all Addon when going to Youtube. If there is a problem try using Private Mode and see what happens with Addon Disabled.

more options

Is there any update for this? I can load same page using Google chrome. Once it got stuck, Stop loading/reloading page and close the tab and open in new one doesn't work. It's really infuriating.

more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

I run firefox browser for few days in Trubleshoot mode, turning off hardware acceleration, and disable userChrome.css but stucking still happens. I also checked task manager on my PC and no other programs are using network bandwidth. This time I can open the page on Chrome, too. I tried tweaking security setting on firefox didn't solve the problem.

I mildly(and wildly) guessing that only google-related website(youtube, google map is the website that I experienced stucking) is being affected.

more options

Are you using a proxy or VPN?

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

more options

Suluhisho teule

This could also be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data = false on the about:config page to disable this feature until this is fixed by Google or Mozilla to see if that helps.

See also:


You can open the about:config page via the location/address bar. If you get the warning page, you can click the "Accept the Risk and Continue" button.

Modified by cor-el