Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Websites not loading properly, getting flagged as security risks

  • 3 majibu
  • 1 ana tatizo hili
  • 6 views
  • Last reply by cor-el

more options

It's not happening to every website, but most sites are getting flagged as a security risk, some sites are not flagged but even then they do not load properly.

Steps taken: -Cleared cache and cookies -Loaded in safe mode -Browser refresh -Complete clean reinstall of Firefox -Checked for malware on the system

None of the following worked, even a clean reinstall does not fix the issue, it can't be extensions because the problem still happened in safe mode, at the end of my rope here on my end. Has anyone else ran into this problem before? If so how did you fix it? Any suggestions?

Attached screenshots

All Replies (3)

more options

In screenshot 1 and 3, press the Advanced button. What do they say?

In screenshot 2, It looks like the web page is not loading properly. Load the web page. Then, to reload the page bypassing the cache and force a fresh retrieval; Ctrl+Shift+R (Mac=Command+Shift+R)

Try this several times.

Helpful?

more options

Helpful?

more options

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Helpful?

Uliza swali

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.