Sök i support

Akta dig för supportbedrägerier: Vi kommer aldrig att be dig att ringa eller skicka ett sms till ett telefonnummer eller dela personlig information. Rapportera misstänkt aktivitet med alternativet "Rapportera missbruk".

Learn More

firefox save image to .txt file when dragging to desktop

  • 3 svar
  • 1 har detta problem
  • 49 visningar
  • Senaste svar av Med

more options

Hello, when dragging an image to desktop firefox not save to .JPG, .GIF or .PNG but creates a .txt file :-/ No probleme with other browsers ! Video demo : http://videobam.com/OTMPC

Any idea ?

Vald lösning

Hi @Redel, no problem with incognito mode or pluging but just as said @guigs2 (Hi again) with "application stored options" !

To solved without "The Reset Firefox feature" i have edit "mimeTypes.rdf" found in my profile folder

i have change :

NC:description="Document texte"

to :

NC:description="Image PNG"

and

<NC:fileExtensions>txt</NC:fileExtensions>

to :

<NC:fileExtensions>png</NC:fileExtensions>

Thank you very much for your reply and help.

Läs svaret i sitt sammanhang 👍 0

Alla svar (3)

more options

Hey SMed79, Thank you for your question. I understand that you are dragging and dropping an image to the desktop and are seeing a txt file. Try this not in a private window.

Please see the application stored options on your Firefox menu bar to see if there is a preference stored that saves this. I was unable to reproduce this.

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions and some Preferences.

  • Open websites will not be saved in Firefox versions lower than 25.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

Ändrad av guigs

more options

Hi SMed79,

If the problem is founded in Firefox settings, guigs2's recommendation of resetting the browser will likely fix it. I cannot reproduce your issue or your browser. I believe you to be using an outdated version of Firefox. It is possible that the functionality of drag and drop in a private window could be different in the version you're using.

I noticed two things from your video:

  1. You are using incognito mode on your browser
  2. You have a minimal number of icons on your desktop and are referencing the non-tracking search engine Duck Duck Go.

These things make me believe that you are a highly security conscious individual (my brother!) and I believe that may be an angle to look at. Overzealous plugins or misconfigured settings are very likely the cause, but you might want to explore local issues. The file is being saved as a v102 extension. A simple search turned up nothing regarding that extension. I have no idea what it is. The interesting thing is that not only is your computer saving images as this extension, but associating it with text editor, which argues it's an extension recognized to your computer. I would explore local programs for anything with that extension. It could be anything from specialized security (forensics, etc) software overwriting default file extensions to a local virus, might be a cryptolocker variation at worst.

Ändrad av Redel

more options

Vald lösning

Hi @Redel, no problem with incognito mode or pluging but just as said @guigs2 (Hi again) with "application stored options" !

To solved without "The Reset Firefox feature" i have edit "mimeTypes.rdf" found in my profile folder

i have change :

NC:description="Document texte"

to :

NC:description="Image PNG"

and

<NC:fileExtensions>txt</NC:fileExtensions>

to :

<NC:fileExtensions>png</NC:fileExtensions>

Thank you very much for your reply and help.