X
Tryck här för att gå till den mobila versionen av webbplatsen.

Supportforum

How to disable password updating ?

Skickad

I log into an internal website multiple times a day. In the login form, I am required to enter a password.

The password I must enter is (ex.:) "boat123". Upon hitting the "Login" button, the code on the page changes the password to some other encrypted version then submits the information. Thus, the password I entered and the password submitted are different. Firefox sense this change and asks me if I want to update the password every single time. I find this behavior very annoying since I can't use the site with the "updated version" of the password, only the one I type in.

Is there a way to tell Firefox to not ask me to update my password OTHER THAN disabling password saving altogether ?

Thanks.

I log into an internal website multiple times a day. In the login form, I am required to enter a password. The password I must enter is (ex.:) "boat123". Upon hitting the "Login" button, the code on the page changes the password to some other encrypted version then submits the information. Thus, the password I entered and the password submitted are different. Firefox sense this change and asks me if I want to update the password every single time. I find this behavior very annoying since I can't use the site with the "updated version" of the password, only the one I type in. Is there a way to tell Firefox to not ask me to update my password OTHER THAN disabling password saving altogether ? Thanks.

Vald lösning

FredMcD : Thanks for lighting a spark in my head!

Here's how I solved the problem :

  1. Clean any saved password you have for the affected website.
  2. Install the "Saved Password Editor 2.7.1" addon.
  3. Have Firefox save the wrong password once.
  4. Go into the addon's personalized password manager.
  5. Edit the password and save the popup as an image for future reference.
  6. Clean any saved password you have for the affected website (again).
  7. Go to the website, log in and this time, refuse to save the password. This will put the website on the exception list.
  8. Go into the addon's personalized password manager.
  9. Create a new saved password and enter the informations as stated in the printscreen from previous step, but input the right password.

MAGIC! Firefox will auto complete the website's information AND will not ask for an update to the password.

It's a shady workaround for an option that should be included, but it works!

Enjoy!

Läs svaret i sitt sammanhang 0

Ytterligare systemdetaljer

Installerade tillägg

  • Google Update
  • Shockwave Flash 11.9 r900
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20913.0
  • VLC media player Web Plugin 2.0.2
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634

Applikation

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:26.0) Gecko/20100101 Firefox/26.0

Mer information

gnittala 25 lösningar 307 svar

Hello, Can you please confirm if

  1. You have enabled Firefox to store the password on the site earlier. You can find this by selecting Firefox -> Preferences -> Security -> Saved Passwords. Please check if the intranet site and the username are listed on the dialog
  2. After you have saved this password, did you change the password on the intranet site?

I am trying to determine if Firefox wants to update the saved password that is stored in Firefox.

Thank you

Hello, Can you please confirm if #You have enabled Firefox to store the password on the site earlier. You can find this by selecting Firefox -> Preferences -> Security -> Saved Passwords. Please check if the intranet site and the username are listed on the dialog #After you have saved this password, did you change the password on the intranet site? I am trying to determine if Firefox wants to update the saved password that is stored in Firefox. Thank you

Frågans ägare

Yes, the password is saved in Firefox's Password Manager. I had to download and use the "Saved Password Editor 2.7.1" addon to manually change the remembered password from the encrypted version to "boat123" so the login would work.

Yes, the password is saved in Firefox's Password Manager. I had to download and use the "Saved Password Editor 2.7.1" addon to manually change the remembered password from the encrypted version to "boat123" so the login would work.

Hjälpsamt svar

So the logical order would be :

  1. Firefox enters "boat123" in the password field.
  2. I press submit.
  3. The page's code changes the password to the encrypted version.
  4. Firefox sense the password has changed.
  5. Firefox asks me if I want to save the "new" password.

I understand this is an acceptable and normal behavior. I just want to disable it to fit my intranet's webpage very situational quirk. :)

So the logical order would be : # Firefox enters "boat123" in the password field. # I press submit. # The page's code changes the password to the encrypted version. # Firefox sense the password has changed. # Firefox asks me if I want to save the "new" password. I understand this is an acceptable and normal behavior. I just want to disable it to fit my intranet's webpage very situational quirk. :)
gnittala 25 lösningar 307 svar

Hjälpsamt svar

You can change the remembered password from the dialog itself. Once you changed the password, are you seeing the prompt to update the password?

You can change the remembered password from the dialog itself. Once you changed the password, are you seeing the prompt to update the password?

Frågans ägare

From what I can tell, I can't change the password from the prompt itself. I have the option to either "Update password" (which I don't want to do) or "Not Now".

If I do accept to update the password, it saves the encrypted version which gets reencrypted thus leading to an "access denied" on the next login attempt.

From what I can tell, I can't change the password from the prompt itself. I have the option to either "Update password" (which I don't want to do) or "Not Now". If I do accept to update the password, it saves the encrypted version which gets reencrypted thus leading to an "access denied" on the next login attempt.
FredMcD
  • Top 10 Contributor
1074 lösningar 15628 svar

Firefox Options > Security. Look for Remember Passwords. To the right is a button called Exceptions. If you tell Firefox to save passwords, it will always ask about new passwords.

'''''Firefox Options > Security'''''. Look for '''''Remember Passwords'''''. To the right is a button called '''''Exceptions'''''. If you tell Firefox to save passwords, it will always ask about new passwords.
John99
  • Top 10 Contributor
  • Moderator
748 lösningar 10207 svar

Rather a clumsy workaround but try this.
Take advantage of the fact that Firefox may store multiple passwords for a single site.
Set up an additional username and password in Firefox. Use that day today by deleting the last character of the username when signing in. It is then irrelevant what password is stored with the true user name; you do not actually use it.

  1. Allow Firefox to save your login details
    • Use the unaltered password as entered prior to encryption entered password
    • But with an extra character on the end of the user name name*
    • This will store but will not allow you to login as is.
  2. Allow Firefox to store the details as used
    • Again Use the unaltered password as entered prior to encryption enreredpasword
    • Use the correct username (no additional character)
  3. In future every time you wish to login opt for the false longer user name. That has the correct plaintext, unencrypted, password. Just delete the additional character and sign in. Do not accept offers to update this or you are in the same position as before.
Rather a clumsy workaround but try this. <br />Take advantage of the fact that Firefox may store multiple passwords for a single site. <br />Set up an additional username and password in Firefox. Use that day today by deleting the last character of the username when signing in. It is then irrelevant what password is stored with the true user name; you do not actually use it. *Look a this article for information on how to view your passwords<br />[[Password manager - Remember, delete and change saved passwords in Firefox]] * It is not possible to directly edit these. They are encrypted and two files are used. For technical background information see <br /> http://kb.mozillazine.org/Password_Manager #Allow Firefox to save your login details #* Use the unaltered password as entered prior to encryption ''entered password'' #* But with an extra character on the end of the user name ''name*'' #* This will store but will not allow you to login as is. # Allow Firefox to store the details as used #* Again Use the unaltered password as entered prior to encryption ''enreredpasword'' #* Use the correct username (no additional character) # In future every time you wish to login opt for the false longer user name. That has the correct plaintext, unencrypted, password. Just delete the additional character and sign in. Do not accept offers to update this or you are in the same position as before.

Frågans ägare

FredMcD : Thanks for the heads up. I see that I can't disable the prompt now.

john99 : Thanks for the effort, but between removing/adding a character to submit and pressing X on the "Update password" prompt, I see less downsides using the current method.

Until there is an option to "Never ask to update password again" available in Firefox, I don't see this problem being resolved. I can't mark this problem as solved since the option is unavailable, but I see I won't get the answer I'm looking for.

Thanks everyone for the efforts! :)

FredMcD : Thanks for the heads up. I see that I can't disable the prompt now. john99 : Thanks for the effort, but between removing/adding a character to submit and pressing X on the "Update password" prompt, I see less downsides using the current method. Until there is an option to "Never ask to update password again" available in Firefox, I don't see this problem being resolved. I can't mark this problem as solved since the option is unavailable, but I see I won't get the answer I'm looking for. Thanks everyone for the efforts! :)
FredMcD
  • Top 10 Contributor
1074 lösningar 15628 svar

Follow my prior instruction and enter that website into the Exceptions list and see what happens.

Follow my prior instruction and enter that website into the '''''Exceptions''''' list and see what happens.

Frågans ägare

I see no way to enter a new website in this list from the windows poping from following your instructions.

I see no way to enter a new website in this list from the windows poping from following your instructions.

Vald lösning

FredMcD : Thanks for lighting a spark in my head!

Here's how I solved the problem :

  1. Clean any saved password you have for the affected website.
  2. Install the "Saved Password Editor 2.7.1" addon.
  3. Have Firefox save the wrong password once.
  4. Go into the addon's personalized password manager.
  5. Edit the password and save the popup as an image for future reference.
  6. Clean any saved password you have for the affected website (again).
  7. Go to the website, log in and this time, refuse to save the password. This will put the website on the exception list.
  8. Go into the addon's personalized password manager.
  9. Create a new saved password and enter the informations as stated in the printscreen from previous step, but input the right password.

MAGIC! Firefox will auto complete the website's information AND will not ask for an update to the password.

It's a shady workaround for an option that should be included, but it works!

Enjoy!

FredMcD : Thanks for lighting a spark in my head! Here's how I solved the problem : # Clean any saved password you have for the affected website. # Install the "Saved Password Editor 2.7.1" addon. # Have Firefox save the wrong password once. # Go into the addon's personalized password manager. # Edit the password and save the popup as an image for future reference. # Clean any saved password you have for the affected website (again). # Go to the website, log in and this time, refuse to save the password. This will put the website on the exception list. # Go into the addon's personalized password manager. # Create a new saved password and enter the informations as stated in the printscreen from previous step, but input the right password. MAGIC! Firefox will auto complete the website's information AND will not ask for an update to the password. It's a shady workaround for an option that should be included, but it works! Enjoy!
FredMcD
  • Top 10 Contributor
1074 lösningar 15628 svar

Glad you found the way. Good luck.

Glad you found the way. Good luck.