Sök i support

Akta dig för supportbedrägerier: Vi kommer aldrig att be dig att ringa eller skicka ett sms till ett telefonnummer eller dela personlig information. Rapportera misstänkt aktivitet med alternativet "Rapportera missbruk".

Learn More

no sound from translate.google.com

  • 6 svar
  • 24 har detta problem
  • 15 visningar
  • Senaste svar av BahtSimpson

more options

On translate.google.com web page, there is an icon to listen to the word or phrase being spoken. This does not work on Firefox. It works on Google Chrome.

Alla svar (6)

more options

Hello BahtSimpson, Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.


Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Hi ideato,

Thanks very much for your quick response.

I restarted Firefox with Add-ons disabled, but the problem remained.

I then created a fresh profile (run firefox.exe -p) and the problem was gone.

So now the question is, what is the difference between "Add-ons disabled" and a new profile?

I am using Firefox 26.0, the default theme, 12 plugins and <ahem> 92 extensions.

They all work happily together, apart from this problem which probably started several weeks ago.

If you like, I can post a list of all the Add-ons.



more options

Hello Baht, it is great that a new profile solve the issue. A lot of things is inside the profile that maybe be corrupted after some time in firefox !

see for more information and to transfer your data into new profile: Transferring data to a new profile - Firefox

Files and folders in the profile

thank you

more options

Did this problem just start in Firefox 26?

For me, Google Translate is using Flash to play the sound. If you had Flash set to "Ask to Activate" instead of "Always Activate" that could be a difference from the default settings in a new profile.

Most of the relevant preferences probably would be in the prefs.js files in the respective profile folders. Setting aside printer and date information, the file consists largely of preferences modified through the UI, or the about:config preferences editor, or by add-ons. Could be looking for a needle in a haystack, but if you want to look, that's the haystack I suggest starting with.

more options

Hi jscher2000,

No, I've already tried FF versions 25.0.1, 25 and 24 (with my current profile) and they all produce no sound with translate.google.com.

I was thinking of going back to even earlier versions, but then recalled that the new profile in 26 is OK, so thought I'd better re-add all my extensions to that profile.

Actually, one of my "important" extensions was broken in Firefox 26 (Download Manager Tweak) so I have reverted back to v 25.0.1.

A new profile in FF v 25.0.1 also produces sounds in translate.google.com

Regarding Flash, I thought you had hit on a winner there, as I had recently changed my Flash settings. But the current settings are:

Storage - Allow sites to save information on this computer Camera and mic - Ask me Playback - Ask me Advanced - Notify me to install

I have another PC - a Samsung Netbook - which suffers the exact same problem as I have described above, all of which relates to my desktop PC.

Finally (I write this about an hour after the previous comments), I have started up my old Acer Laptop, which is also running FF v 25.0.1 and has roughly the same extensions installed - 91, not 92.

However, translate.google works! Unbelievable!

So I am now investigating the differences between the 3 computers in order to find the problem.

One point to note is that rather than configure all 92 extensions on the Netbook (which I only recently acquired), what I did was to install them all and then copy the entire contents of the Desktop profile folder - including pref.js - to the profile folder on the Netbook.

All the extensions then appeared configured correctly on the Netbook, but also the problem with the sound was copied across.

I'll let you know what I find but if you have any thoughts, please post them.

more options

Thanks for the links, ideato. I'm sure I've been to those web pages before!

As you can see from my long reply above, I'm looking into why one of my PCs works OK on translate.google.com (the old Laptop), but the Desktop and the new Netbook don't.

I don't like mysteries so will persevere with this for a while and report back.

But eventually I may just have to re-add and re-configure all my extensions on the Desktop and Netbook.