On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Sök i support

Akta dig för supportbedrägerier: Vi kommer aldrig att be dig att ringa eller skicka ett sms till ett telefonnummer eller dela personlig information. Rapportera misstänkt aktivitet med alternativet "Rapportera missbruk".

Learn More

am using an up to date fire fox 6 but face book ,twitter and thers keep telling me that am using an old version of Internet Explorer

  • Inga svar
  • 1 har detta problem
  • 22 visningar
more options

am using an up to date fire fox version 6 but web sites like face book, twitter keep telling me that am using an old version of Internet Explorer!

am using an up to date fire fox version 6 but web sites like face book, twitter keep telling me that am using an old version of Internet Explorer!