Sök i support

Akta dig för supportbedrägerier: Vi kommer aldrig att be dig att ringa eller skicka ett sms till ett telefonnummer eller dela personlig information. Rapportera misstänkt aktivitet med alternativet "Rapportera missbruk".

Learn More

Stopping Ask.com autoattaching in keyword based search

more options

I'm the one who previously asked on http://support.mozilla.com/pl/forum/1/441842 about integration between firefox address bar and google search engine. The steps provided gave the solution for my problem, and it lasted for several week. But now I always had the same problem and had to always clear the keyword feature in about:config everytime it happened. It seems that ask.com has set my settings automatically, and i have no idea what triggered this. I will be really grateful if Firefox can show me the way to restrict ask.com to change my settings in keyword so that when i type keywords in address bar, I will only have google to handle it. It will be convenient to me because some of my keywords which are obviously an address of site will get me redirected to that site and i always use this way to browse. with ask.com, no quick redirection, and worse result on searching, also can't use some of the search features of those in google.com I will be really grateful for the help.

I'm the one who previously asked on http://support.mozilla.com/pl/forum/1/441842 about integration between firefox address bar and google search engine. The steps provided gave the solution for my problem, and it lasted for several week. But now I always had the same problem and had to always clear the keyword feature in about:config everytime it happened. It seems that ask.com has set my settings automatically, and i have no idea what triggered this. I will be really grateful if Firefox can show me the way to restrict ask.com to change my settings in keyword so that when i type keywords in address bar, I will only have google to handle it. It will be convenient to me because some of my keywords which are obviously an address of site will get me redirected to that site and i always use this way to browse. with ask.com, no quick redirection, and worse result on searching, also can't use some of the search features of those in google.com I will be really grateful for the help.

Alla svar (2)

more options

probably ask.com toolbar is interfering with your settings. no not the addon but the software ask.com. you may try to go to add remove programs and look for anything that contains the string ask.com and remove that program.

in future please be careful while installing any free software. these days many of them allow ask.com to piggy back on it.

after that you may set your about:config key as --

keyword.url ===> http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

more options

I hadn't tried to uninstall it from the add and remove programs and now i have. It works so far. Probably the problem IS in some software i installed that have ask.com piggied on it. I wonder if there's any way to not allow firefox get interfered by any search engine software so easily, and without any prompting. Of course it will bother so many people when they download files from the web and it has such an autoinstall execution.