Sök i support

Akta dig för supportbedrägerier: Vi kommer aldrig att be dig att ringa eller skicka ett sms till ett telefonnummer eller dela personlig information. Rapportera misstänkt aktivitet med alternativet "Rapportera missbruk".

Learn More

Office 365 cookie issue

  • 19 svar
  • 1 har detta problem
  • 128 visningar
  • Senaste svar av jonzn4SUSE

more options

I have configured FF to block all cookies under "Browser Privacy" the custom setting allows "Choose which trackers and scripts to block. and I selected "all cookies". Knowing that all cookies will be blocked I logged into office 365 and allowed manually cookies through "view page info" I then selected "set cookies" to allow expecting full access to office 365 mail, but this did not occur. What happened is I logged into office 365 and could see the icons and my login name but could not read the mail.

Office 365 gave the message "we couldn't sign you in please try again" yet I could see my log in name and the office 365 icons for mail, calendar etc.. just not the actual data. If I allow cookies in Browser privacy (which i take it allows cookies always) it woks.

I bring this up because it seems like something is missing in cookies that is not represented in FF.What is the difference between browser privacy cookies and allowing it through view page permissions? Can anyone offer an explanation?

Bifogade skärmdumpar

Alla svar (19)

more options

On the same Privacy & Security page in Options/Preferences, there is a button labelled "Manage Exceptions". You can use that to allow cookies on the domain(s) you wish.

more options

The message I receive when I open manage exceptions is "you've turned off protections on thee websites" There are no values in the box and I cannot enter any new values.

more options

When I open it, there is a text area at the top for "Address of web site" and below that buttons to 'Block', "Allow for session" and 'Allow'.

more options

Via "Tools -> Page Info -> Permissions" you only allow cookies for this listed domain (login.microsoftonline.com). It is likely that you need to allow cookies for more domains to make this work properly. You can check what cookies get created if you temporarily allow all third-party cookies or at least for visited domains.

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"
more options

Your original screenshot of the Page Info dialog is for login.microsoftonline.com, not for office365.com or office.com.

Try using the Manage Permissions/Manage Exceptions button to allow cookies for the two Outlook domains:

more options

The domain is correct as I can connect if I enable cookies in browser privacy. What i have done is have cookies disabled and enabled it manually to regain connectivity but that does not work and I do not know what is missing to get functionality.

more options

It's not surprising that sites which require an ongoing session break when you disable cookies. That is what Firefox says will happen right there on the Preferences page. Whatever approach you are using to create Allow exceptions is not working. Here's a thought:

  • Create a new profile with default settings (see steps below the line)
  • Open the Preferences page to the Cookies and Site Data section, click Manage Data, and remove all
  • Open a new tab and log in to Office365, making sure you can get to your mailbox
  • Switch back to the Preferences page, click Manage Data, and make a note or screenshot of all the servers listed there that set cookies during the process

You might need to create Allow exceptions for many or most of those servers in your regular profile to get the site working.


New Test Profile

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Take a quick glance at the page and make a mental note of which Profile has this notation: This is the profile in use and it cannot be deleted. That is your current default profile.

Click the "Create a New Profile" button, then click Next. Assign a name like Jan2021, ignore the option to relocate the profile folder, and click the Finish button.

Firefox will switch your default profile to the new one, so click the Set as Default Profile button for your regular one to avoid an unwanted surprise at your next startup.

Scroll down to Jan2021 and click its Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system to get a clean test.

Do your testing...

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Jan2021 will remain available for future testing.)

more options

With Block all cookies is enabled in privacy & security settings I can not manually enable cookies for specific web sites? If that is the case why is there an option (shown in previous attachment) to "allow cookies" "allow session" for cookies? this suggests that for that page even though my original privacy & security setting is set to block all cookies you can override the blocked cookies.

Keep in mind this is not a problem with FF as it will connect to the site if I allow cookies. but with cookies set off and I do not allow manual permissions of the cookies it won't even let me log in. The manual permissions seem to allow me to log in but some component is still missing. I am trying to find the reason for the failure, what is missing that it cannot continue to the web site even though manually cookies are allowed?

more options

Mace2 said

With Block all cookies is enabled in privacy & security settings I can not manually enable cookies for specific web sites? If that is the case why is there an option (shown in previous attachment) to "allow cookies" "allow session" for cookies? this suggests that for that page even though my original privacy & security setting is set to block all cookies you can override the blocked cookies.

Okay. I already gave you my suggestion for next steps since your current exception list isn't working.

more options

I wrote above that you can temporarily allow all cookies and then check for what domains cookies are created. You can add exceptions for MS domains and others like outlook and office domains, obviously you can ignore third-party ad domains. An exception for the top level includes sub levels (https:office.com includes outlook.office.com). Once you have set exception you can clear existing cookies for these domains and then check if the exception work if you block all cookies once again.

more options

Cor-el I did use your process to enable cookies (Via "Tools -> Page Info -> Permissions" you only allow cookies for this listed domain )

But with cookies blocked in "privacy and security" "Enhanced tracking protection" FF almost logs into office 365. Office knows my name and email address but does not show my emails. Soemthing is missing I and I would like to know what the missing component is. See enclosed after allowing, Via "Tools -> Page Info -> Permissions" you only allow cookies for this listed domain .

more options

There is something wrong with FF handling of office 365. with Cookies enabled when I log out I get the following message.

more options

^That error with not being able to logout is not a real Firefox problem, but is about how MS setup their email pages and is using a lot of domains. I used to get such an error in the past and this is a problem with not allowing access to third-party cookies (they want to remove cookies for various domains when you log out). It was only possible to logout properly when you enabled all third-party cookies, but that gives you a large flood of third-party cookies. Enabling all third-party cookies is not acceptable and was one of the reasons to stop using Hotmail/outlook apart from other issues where MS was taking time to ensure Firefox was supported properly (i.e. it was working on and off).

  • /questions/748027 I have enabled my cookies as per the help information, but still some sites say cookies need to be enabled to access or logout

Ändrad av cor-el

more options

I do not think this issue is an office 365 issue. I have reinstalled FF from a default profile and it works even the logoout is acknowledged.

I have noticed issues where when I go to a specific web site like youtube.com it stalls and never recovers when I go to about:networking#dnslookuptool it is able to resolve the IP address but produces

HTTP RRs NS_ERROR_UNKNOWN_HOST

I am suspecting this problem resolving via DOH is causing corruption.

more options

Can you show this when on the site? see screenshots Something is clearly being blocked. I'm in Hotmail / Office 365 everyday with no issues.

more options

The failure to respond under DOH is infrequent. But I have an example for youtube. You will notice it resolves the IP address but produces the error.

more options

It appears like FF 85 may address my problems with an issue of super cookies.

more options

version 85 corrects this issue

more options

Good. Mark it solved.