Sök i support

Akta dig för supportbedrägerier: Vi kommer aldrig att be dig att ringa eller skicka ett sms till ett telefonnummer eller dela personlig information. Rapportera misstänkt aktivitet med alternativet "Rapportera missbruk".

Learn More

Firefox doesn't play any sound on any website. All other apps play sound on my computer

  • 2 svar
  • 1 har detta problem
  • 223 visningar
  • Senaste svar av James

more options

System Details: Ubuntu 18.04, Firefox 65 Firefox doesn't play any sound on any website,other apps play. Firefox does show the speaker icon on the tab that is playing video/audio

I have tried https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

I think i have this problem from the day i connected my PC to TV through HDMI and played a video on firefox - Maybe firefox is still using the wrong device(HDMI TV)(I have checked Ubuntu Sound Output is set to inbuilt speaker not HDMI)

System Details: Ubuntu 18.04, Firefox 65 Firefox doesn't play any sound on any website,other apps play. Firefox does show the speaker icon on the tab that is playing video/audio I have tried https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues I think i have this problem from the day i connected my PC to TV through HDMI and played a video on firefox - Maybe firefox is still using the wrong device(HDMI TV)(I have checked Ubuntu Sound Output is set to inbuilt speaker not HDMI)

Vald lösning

davidspriggs, this is on Linux (Ubuntu) and not on Windows.

Rahulj Firefox uses PulseAudio though Ubuntu has its own custom sound indicator that will allow you to select the preferred device and control the volume of each application.

Läs svaret i sitt sammanhang 👍 0

Alla svar (2)

more options

Select the Start button, type Device Manager in the search box, and then select Device Manager from the list of results. Under Sound, video and game controllers, select your sound card, open it, select the Driver tab, and then select Update Driver. If Windows doesn't find a new driver, look for one on the device manufacturer's website and follow their instructions.

   If that didn't work, try this:
       Uninstall your audio driver: in Device Manager, right-click (or press and hold) the audio driver, and then select Uninstall. Restart your device and Windows will attempt to reinstall the driver.
   And if that didn't work, try using the generic audio driver that comes with Windows. Here's how:
       Open Device Manager, right-click (or press and hold) your audio driver > Update driver > Browse my computer for driver software > Let me pick from a list of device drivers on my computer, select High Definition Audio Device, select Next, and follow the instructions to install it.

Set default device

If you're connecting to an audio device using USB or HDMI, you might need to set that device as the default.

   Select the Start  button, type Sound in the search box, and then select Sound from the list of results. On the Playback tab, select a device, then Set Default.
more options

Vald lösning

davidspriggs, this is on Linux (Ubuntu) and not on Windows.

Rahulj Firefox uses PulseAudio though Ubuntu has its own custom sound indicator that will allow you to select the preferred device and control the volume of each application.