Sök i support

Akta dig för supportbedrägerier: Vi kommer aldrig att be dig att ringa eller skicka ett sms till ett telefonnummer eller dela personlig information. Rapportera misstänkt aktivitet med alternativet "Rapportera missbruk".

Learn More

Set Ffox 60.0.1 to block all cookies; one site can still set cookies, how to fix?

  • 3 svar
  • 1 har detta problem
  • 7 visningar
  • Senaste svar av cor-el

more options

Hi Firefox folks. Using Quantum v. 60.0.1. I delete cookies not needed after each session, but noticed a cookie appearing from a site even after deleting so I did a test. I set cookies to "Always block," and closed Firefox. Opened Firefox and visited the site. Checked the "Manage Data" window under "Privacy" and there was a cookie from that site, despite the setting of "Always Block." I deleted that one cookie, then visited several sites and none could set a cookie. I went back to that one site in question, then checked the "Manage Data" panel and there was a new cookie from that site. I checked this several times, and even though Firefox is set to "Always Block" cookies, the one site sets a cookie every visit. No other sites seem to be able to override the "Always Block" setting. I followed the following instructions from the Firefox support page, copied below, and it made no difference. I'm not worried about the cookie from the site, but I want to be able to rely on Firefox settings to do what they claim to do. Anyone know how to fix this? Thanks.

Firefox instructions copied, pasted below. They did not fix the problem.

Found at: https://support.mozilla.org/en-US/kb/block-websites-storing-site-preferences

Block cookies for a single website You can use the Page Info window to set Firefox to block cookies from one website: 1. Go to the website you wish to block from setting cookies in Firefox. 2. Right-clickHold down the Ctrl key while you click within the page and select View Page Info. 3. In the Page Info window, select the Permissions panel. 4. Underneath Set Cookies, remove the check mark from Use Default. 5. Change the setting to Block.  

 6. Close the Page Info window. Remove any cookies that the website has already set in Firefox. For instructions, see Delete cookies to remove the information websites have stored on your computer.

-- Following the above instructions did not stop the site from setting a cookie when visiting the site.

Hi Firefox folks. Using Quantum v. 60.0.1. I delete cookies not needed after each session, but noticed a cookie appearing from a site even after deleting so I did a test. I set cookies to "Always block," and closed Firefox. Opened Firefox and visited the site. Checked the "Manage Data" window under "Privacy" and there was a cookie from that site, despite the setting of "Always Block." I deleted that one cookie, then visited several sites and none could set a cookie. I went back to that one site in question, then checked the "Manage Data" panel and there was a new cookie from that site. I checked this several times, and even though Firefox is set to "Always Block" cookies, the one site sets a cookie every visit. No other sites seem to be able to override the "Always Block" setting. I followed the following instructions from the Firefox support page, copied below, and it made no difference. I'm not worried about the cookie from the site, but I want to be able to rely on Firefox settings to do what they claim to do. Anyone know how to fix this? Thanks. Firefox instructions copied, pasted below. They did not fix the problem. Found at: https://support.mozilla.org/en-US/kb/block-websites-storing-site-preferences Block cookies for a single website You can use the Page Info window to set Firefox to block cookies from one website: 1. Go to the website you wish to block from setting cookies in Firefox. 2. Right-clickHold down the Ctrl key while you click within the page and select View Page Info. 3. In the Page Info window, select the Permissions panel. 4. Underneath Set Cookies, remove the check mark from Use Default. 5. Change the setting to Block.  

 6. Close the Page Info window. Remove any cookies that the website has already set in Firefox. For instructions, see Delete cookies to remove the information websites have stored on your computer. -- Following the above instructions did not stop the site from setting a cookie when visiting the site.

Alla svar (3)

more options

Separate Security Issue, please update your Flash 29.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Reinstall with Flash Player Version: 30.0.0.134 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Are you using and ad-blockers as no info was included with your question. Are you taking into account Flash cookies as guess do not delete them.

So without more info to go on. All I can do is make suggestions : uBlock Origin https://addons.mozilla.org/firefox/addon/ublock-origin/

Also the site we have no info on and your not sharing, There is things called persistent cookies which is like what you have.

I do not know if this works on a mac https://addons.mozilla.org/firefox/addon/malwarebytes/

If have some malware on board : https://www.malwarebytes.com/mac/

more options

Thanks for quick reply. Took a while to find my way back to this page to reply. 1. I just updated the Flash Player to the most recent, directly from the Adobe site.

2. Plug-ins are:

 - Widevine module, only activated when I need it to view a rental movie, otherwise left in Never Activate setting.

- Shockwave module, set to Ask To Activate for when it needs to run it will ask. - Cisco video codec installed by Mozilla when Firefox updated. There are no extensions.

3. There is an ad blocker but I'm not sure where to find it -- it doesn't show in plug-ins or extensions. The ad blocker is in protection mode when I visit the site that always overrides the Always Block cookie setting.

4. I'm aware of Flash Cookies and regularly check the Adobe/Macromedia Flash Cookie manager to make sure there are none. I know some sites can (or used to) set a Flash Cookie that will then replace browser cookies that are deleted by the user. The settings there hold well and always show no Flash Cookies, as it should.

5. The site is a news site, nothing special -- "spectator.org."

6. I know of Malwarebytes, and they do have a Mac version. I ran it and it shows no malware.

It does seem like some kind of persistent cookie.

It would be good to know if it's some kind of super cookie that site is using to defeat the wishes of visitors to that site, or if it's something within Firefox.

Thanks for your time and attention. Any further info will be appreciated.

more options

If clearing cookies didn't help then It is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

  • rename/remove cookies.sqlite (cookies.sqlite.old) and if present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.