X
Tryck här för att gå till den mobila versionen av webbplatsen.

Supportforum

mimetype action

  • Inga svar
  • 1 har detta problem
  • 6 visningar
Skickad

I have created a new mimetype according to this documentation:

https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/desktop_migration_and_administration_guide/file_formats

Everything works fine, in a file browser the application starts when I click on the file. It also works when I get the file over a simple web page and firefox adds the new mimetype to <profile>/mimeTypes.rdf. I reduced the file to the new lines and that is what firefox adds to the file:

<RDF:RDF xmlns:NC="http://home.netscape.com/NC-rdf#"

        xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
 <RDF:Seq RDF:about="urn:mimetypes:root">
   <RDF:li RDF:resource="urn:mimetype:application/x-tcsimxml"/>
 </RDF:Seq>
 <RDF:Description RDF:about="urn:mimetype:application/x-tcsimxml"
                  NC:value="application/x-tcsimxml">
   <NC:handlerProp RDF:resource="urn:mimetype:handler:application/x-tcsimxml"/>
 </RDF:Description>
 <RDF:Description RDF:about="urn:mimetype:handler:application/x-tcsimxml"
                  NC:useSystemDefault="true"
                  NC:alwaysAsk="false" />
 <RDF:Description RDF:about="urn:mimetypes">
   <NC:MIME-types RDF:resource="urn:mimetypes:root"/>
 </RDF:Description>

</RDF:RDF>


But if a complex web application offers such a file, only the download option is offered, as shown in the attachment firefox-only-download-offered.jpg. Only when I add two mor lines to mimeTypes.rdf so that it looks like this:

<RDF:RDF xmlns:NC="http://home.netscape.com/NC-rdf#"

        xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
 <RDF:Seq RDF:about="urn:mimetypes:root">
   <RDF:li RDF:resource="urn:mimetype:application/x-tcsimxml"/>
 </RDF:Seq>
 <RDF:Description RDF:about="urn:mimetype:application/x-tcsimxml"
                  NC:value="application/x-tcsimxml"
                  NC:fileExtensions="tcsimxml">
   <NC:handlerProp RDF:resource="urn:mimetype:handler:application/x-tcsimxml"/>
 </RDF:Description>
 <RDF:Description RDF:about="urn:mimetype:handler:application/x-tcsimxml"
                  NC:useSystemDefault="false"
                  NC:alwaysAsk="false" >
   <NC:externalApplication RDF:resource="urn:mimetype:externalApplication:application/x-tcsimxml"/>
 </RDF:Description>
 <RDF:Description RDF:about="urn:mimetypes">
   <NC:MIME-types RDF:resource="urn:mimetypes:root"/>
 </RDF:Description>

</RDF:RDF>

then I get my application opened.

Is there any way not to edit mimeTypes.rdf by hand, but to tell firefox to add the complete statement to the file?

Or is there a way to provide a system wide default mimeTypes.rdf that will be used when a new profile is created? I didn't find a documentation for that.

Thank you in advance for your help!

I have created a new mimetype according to this documentation: https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/desktop_migration_and_administration_guide/file_formats Everything works fine, in a file browser the application starts when I click on the file. It also works when I get the file over a simple web page and firefox adds the new mimetype to <profile>/mimeTypes.rdf. I reduced the file to the new lines and that is what firefox adds to the file: <?xml version="1.0"?> <RDF:RDF xmlns:NC="http://home.netscape.com/NC-rdf#" xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#"> <RDF:Seq RDF:about="urn:mimetypes:root"> <RDF:li RDF:resource="urn:mimetype:application/x-tcsimxml"/> </RDF:Seq> <RDF:Description RDF:about="urn:mimetype:application/x-tcsimxml" NC:value="application/x-tcsimxml"> <NC:handlerProp RDF:resource="urn:mimetype:handler:application/x-tcsimxml"/> </RDF:Description> <RDF:Description RDF:about="urn:mimetype:handler:application/x-tcsimxml" NC:useSystemDefault="true" NC:alwaysAsk="false" /> <RDF:Description RDF:about="urn:mimetypes"> <NC:MIME-types RDF:resource="urn:mimetypes:root"/> </RDF:Description> </RDF:RDF> But if a complex web application offers such a file, only the download option is offered, as shown in the attachment firefox-only-download-offered.jpg. Only when I add two mor lines to mimeTypes.rdf so that it looks like this: <?xml version="1.0"?> <RDF:RDF xmlns:NC="http://home.netscape.com/NC-rdf#" xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#"> <RDF:Seq RDF:about="urn:mimetypes:root"> <RDF:li RDF:resource="urn:mimetype:application/x-tcsimxml"/> </RDF:Seq> <RDF:Description RDF:about="urn:mimetype:application/x-tcsimxml" NC:value="application/x-tcsimxml" NC:fileExtensions="tcsimxml"> <NC:handlerProp RDF:resource="urn:mimetype:handler:application/x-tcsimxml"/> </RDF:Description> <RDF:Description RDF:about="urn:mimetype:handler:application/x-tcsimxml" NC:useSystemDefault="false" NC:alwaysAsk="false" > <NC:externalApplication RDF:resource="urn:mimetype:externalApplication:application/x-tcsimxml"/> </RDF:Description> <RDF:Description RDF:about="urn:mimetypes"> <NC:MIME-types RDF:resource="urn:mimetypes:root"/> </RDF:Description> </RDF:RDF> then I get my application opened. Is there any way not to edit mimeTypes.rdf by hand, but to tell firefox to add the complete statement to the file? Or is there a way to provide a system wide default mimeTypes.rdf that will be used when a new profile is created? I didn't find a documentation for that. Thank you in advance for your help!
Bifogade skärmdumpar

Ändrad av axel62

Citera

Ytterligare systemdetaljer

Installerade tillägg

  • This plugin provides integration with GNOME Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • The IcedTea-Web Plugin executes Java applets.
  • Next Generation Java Plug-in 11.161.2 for Mozilla browsers
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Applikation

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0

Mer information

Du måste logga in på ditt konto för att svara på inlägg. Starta en ny fråga om du ännu inte har ett konto.