Sök i support

Akta dig för supportbedrägerier: Vi kommer aldrig att be dig att ringa eller skicka ett sms till ett telefonnummer eller dela personlig information. Rapportera misstänkt aktivitet med alternativet "Rapportera missbruk".

Learn More

Firefox not remembering exceptions to session cookies

  • 3 svar
  • 5 har detta problem
  • 234 visningar
  • Senaste svar av FredMcD

more options

I have Firefox 49.0.1 (Windows 8.1) set to keep cookies until Firefox closes. I have set an exception for Google. But I'm having to re-sign in every time I open a browser and try to access my Google accounts. I tried uninstalling Firefox and deleting everything in it's data directory (which was not removed during the uninstall) and then reinstalling Firefox. Previously, firefox was remembering my two-factor authentication key even though I had to sign in each time. After the re-install, Google is now asking even for a new two-factor code every time.

I have the exact same settings (as far as I can tell) on Firefox 47.0.1 on Windows XP and it all works fine.

I have tried following the different suggestions from a google search such as deleting the cookies, clearing the cache, etc.

Vald lösning

Not a very helpful response. Should have been clear from my post that I'm aware of privacy settings as how else would I set an exception.

What worked for me was to change preferences to remember history. Once that worked, I then switched preferences back to keep cookies only until Firefox closes. Everything worked after that.

Läs svaret i sitt sammanhang 👍 1

Alla svar (3)

more options

History and cookies can be removed or not recorded several ways;

  • 1) Running Firefox in Private Mode (nothing is recorded)
  • 2) Privacy settings; (Type about:preferences#privacy<enter> in the address bar.)
  • 3) Many disk cleaners and anti-virus type programs can remove data from browsers. Open their settings and have them leave the browsers alone.
  • 4) Mal-ware.
more options

Vald lösning

Not a very helpful response. Should have been clear from my post that I'm aware of privacy settings as how else would I set an exception.

What worked for me was to change preferences to remember history. Once that worked, I then switched preferences back to keep cookies only until Firefox closes. Everything worked after that.

more options

That was very good work. Well done.