Sök i support

Akta dig för supportbedrägerier: Vi kommer aldrig att be dig att ringa eller skicka ett sms till ett telefonnummer eller dela personlig information. Rapportera misstänkt aktivitet med alternativet "Rapportera missbruk".

Learn More

Blocking identification of browser & PC

  • 6 svar
  • 2 har detta problem
  • 156 visningar
  • Senaste svar av jscher2000

more options

A website with forums knows I'm signed up, so signup page doesn't appear (only Sign In page). How do I stop the site from identifying my browser/PC?

Thank you for any help!

Vald lösning

Andrew said

Where do you see my list of extensions?!

There's a link next to your post listing "More System Details" which is included when you click the green "Share Data" button while posting your question.

The site's ****. You get a fraction of a second of the signup page, then it redirects to the Sign In page.

Google crawls threads that have been marked solved, so not immediately but eventually.

When I visit that site, there is initially a jumble of overlaid content with part of it being the registration form, and then the layout clears up and a large background image fills the entire space below the login form. The registration form still is available if I scroll down; I am not redirected to a different page.


But speaking of scrolling, if you do NOT see the scroll bar, it might be this: There is a bug in Firefox 38 with this combination of circumstances:

(1) You are viewing a page in a private browsing window (2) Tabbed browsing is turned off (3) You click a link which launches the link in a new window (because the site coded the link with target="_blank")

The new window opens without menus, toolbar, scroll bars, etc.

Work on this bug is in process, but I don't know if the fix will be available in the next few weeks. These are the currently known workarounds so you can keep using private browsing windows -- any one of them will work around the bug:

(1) Use tabbed browsing (this is a checkbox under Preferences > General > "Open new windows in a new tab instead");

(2) Shift+click links to open them in a new window with the standard features; or

(3) Change a bunch of hidden settings as explained below -- this will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed.

For #3, here are the steps:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste feat and pause while the list is filtered

(C) For every preference that starts with dom.disable_window_open_feature. if it is not "true", double-click it to switch it to true.

You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.

Läs svaret i sitt sammanhang 👍 1

Alla svar (6)

more options

Most likely Firefox is sending the site back a cookie that it previously set.

To test the cookie theory, try the site in a private browsing window. Either:

  • Ctrl+Shift+p, then load the site
  • right-click a link to the site > Open in New Private Window
  • right-click a bookmark to the site > Open in a New Private Window

Private windows ignore all cookies set in regular windows.

If you want to clear the site's cookies in your normal windows, you can use the Page Info dialog. Either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, the current site's name should be filled in at the top in the search box. If it's not the right name, you can edit that before removing the site's cookies individually.

When you reload the page, the site should stop recognizing your Firefox.


I should note that Firefox supports two other kinds of storage that sites can use in a similar manner to cookies:

  • DOM Storage, also known as local storage
  • Flash Local Storag Objects (or LSOs), sometimes called supercookies

Advertising networks probably are the biggest users of these methods of tracking...

more options
  • Ctrl+Shift+P doesn't work.
  • Right-clicking the bookmark, then Open in a New Private Window does work.

As per original question, signup page doesn't appear, just Sign In page.

"Is this web site storing information (cookies) on my computer?" No


Don't know anything about DOM Storage or LSOs. I use Ghostery extension Ghostery extension to block all ad tracking.

Ändrad av Andrew

more options

I don't have any other blind guesses. Do you want to share the address of the site?

more options

A quick glance at your list of extensions does not lead to a particular suspect but since you have many of them, perhaps you could test in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

more options

No difference.

Where do you see my list of extensions?!

The site's at this address. You get a fraction of a second of the signup page, then it redirects to the Sign In page.

Ändrad av Andrew

more options

Vald lösning

Andrew said

Where do you see my list of extensions?!

There's a link next to your post listing "More System Details" which is included when you click the green "Share Data" button while posting your question.

The site's ****. You get a fraction of a second of the signup page, then it redirects to the Sign In page.

Google crawls threads that have been marked solved, so not immediately but eventually.

When I visit that site, there is initially a jumble of overlaid content with part of it being the registration form, and then the layout clears up and a large background image fills the entire space below the login form. The registration form still is available if I scroll down; I am not redirected to a different page.


But speaking of scrolling, if you do NOT see the scroll bar, it might be this: There is a bug in Firefox 38 with this combination of circumstances:

(1) You are viewing a page in a private browsing window (2) Tabbed browsing is turned off (3) You click a link which launches the link in a new window (because the site coded the link with target="_blank")

The new window opens without menus, toolbar, scroll bars, etc.

Work on this bug is in process, but I don't know if the fix will be available in the next few weeks. These are the currently known workarounds so you can keep using private browsing windows -- any one of them will work around the bug:

(1) Use tabbed browsing (this is a checkbox under Preferences > General > "Open new windows in a new tab instead");

(2) Shift+click links to open them in a new window with the standard features; or

(3) Change a bunch of hidden settings as explained below -- this will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed.

For #3, here are the steps:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste feat and pause while the list is filtered

(C) For every preference that starts with dom.disable_window_open_feature. if it is not "true", double-click it to switch it to true.

You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.