X
Притисните овде да бисте отишли на мобилну верзију сајта.

Сви производи

Java disabled but I still get FF alert on startup

Постављено

I got the Java disabled message:

Missing Java? "For your safety, Firefox has disabled your outdated version of Java. Please upgrade to the latest version."

and I decided I didn't really need Java so I removed it thru the Add/Remove programs feature in Control Panel. The message still pops up every time FF is started. It even comes up in FF safe mode with all add-ons disabled. I updated to ver 12 but that doesn't help either.

How can I stop this alert window from opening every time I start FF?

WinXP FF ver 12

Thanks!

I got the Java disabled message: Missing Java? "For your safety, Firefox has disabled your outdated version of Java. Please upgrade to the latest version." and I decided I didn't really need Java so I removed it thru the Add/Remove programs feature in Control Panel. The message still pops up every time FF is started. It even comes up in FF safe mode with all add-ons disabled. I updated to ver 12 but that doesn't help either. How can I stop this alert window from opening every time I start FF? WinXP FF ver 12 Thanks!

Измењено од стране LocalHero

Изабрано решење

That helps, thanks. I'll install the latest version and go with the two-browser approach.

Прочитајте овај одговор са објашњењем 0

Додатни детаљи о систему

Инсталирани прикључци

  • Shockwave Flash 11.5 r502
  • VLC media player Web Plugin 2.0.2
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • 5.1.10411.0
  • Foxit Reader Plug-In For Firefox and Netscape
  • GEPlugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • Office Plugin for Netscape Navigator

Апликација

  • Кориснички агент: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0

Више информација

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1283 решења 8489 одговора
Постављено

Користан одговор

Ok, well first update to Firefox 18. It's more secure and stable than Firefox 12, which is no longer supported.

Then Reset Firefox Refresh Firefox - reset add-ons and settings

Ok, well first update to Firefox 18. It's more secure and stable than Firefox 12, which is no longer supported. Then Reset Firefox [[Reset Firefox – easily fix most problems]]
Постављено

Користан одговор

Thanks. Funny thing is that I updated from some earlier version before posting this question. I'm not sure why when I asked FF to check for updates it downloaded ver 12 and never even let me know there was a ver 18 available. When it updated to 12, I assumed that was the latest.

Just the update to ver 18 seems to have stopped the java alert page. Reset Firefox is something I've never noticed before but it tells me it will not save extensions or at least extension preferences, site preferences and other stuff that seems like it would be a minor bear to restore.

Thanks for letting me know about ver 18. I'd have never thought to look since I'd just updated.

Thanks. Funny thing is that I updated from some earlier version before posting this question. I'm not sure why when I asked FF to check for updates it downloaded ver 12 and never even let me know there was a ver 18 available. When it updated to 12, I assumed that was the latest. Just the update to ver 18 seems to have stopped the java alert page. Reset Firefox is something I've never noticed before but it tells me it will not save extensions or at least extension preferences, site preferences and other stuff that seems like it would be a minor bear to restore. Thanks for letting me know about ver 18. I'd have never thought to look since I'd just updated.
Постављено

Власник питања

But wait.... another question please! Now with ver 18 I'm getting a message that my "Foxit Reader plugin is known to be vulnerable..." That's good, I'm glad that FF shuts down a plugin automatically when it's a problem. But I'd like to just remove the plugin entirely. There's no "remove" button for plugins like there is for extensions it seems. I also have a disabled Java deployment toolkit plugin that I'd as soon as remove too. Is there a way to remove unwanted plugins?

Thanks again.

But wait.... another question please! Now with ver 18 I'm getting a message that my "Foxit Reader plugin is known to be vulnerable..." That's good, I'm glad that FF shuts down a plugin automatically when it's a problem. But I'd like to just remove the plugin entirely. There's no "remove" button for plugins like there is for extensions it seems. I also have a disabled Java deployment toolkit plugin that I'd as soon as remove too. Is there a way to remove unwanted plugins? Thanks again.
AliceWyman
  • Moderator
195 решења 2266 одговора
Постављено

To remove the Foxit Reader plugin, just uninstall the application from the Windows Control Panel Add/Remove Programs list. Ref: http://www.foxitsoftware.com/support/showfaq_technical.php

The Java deployment toolkit plugin is part of Java but it isn't needed for Java applets to run in Firefox. To remove it, you would have to find the file on your computer and manually delete it. I would Just leave it disabled.

More info:

To remove the Foxit Reader plugin, just uninstall the application from the Windows Control Panel Add/Remove Programs list. Ref: http://www.foxitsoftware.com/support/showfaq_technical.php The Java deployment toolkit plugin is part of Java but it isn't needed for Java applets to run in Firefox. To remove it, you would have to find the file on your computer and manually delete it. I would Just leave it disabled. More info: *[[Use the Java plugin to view interactive content on websites]] *http://kb.mozillazine.org/Java#Java_Deployment_Toolkit_plugin *[[Disable or remove Add-ons]] *[[Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems]]
Постављено

Власник питања

Thanks Alice. I did go to add/remove programs but the java plugin doesn't show up there. I don't mind leaving it disabled if that's the best way.

However now another issue has cropped up. I use a website, zipform.com, that apparently uses Java. So I apparently do need Java. Is there a recommended policy to use Java as safely as possible? Does it make sense to install Java only on IE (which I don't normally use) and leave it disabled except for when I need to use zipform.com? I don't use it that often and it wouldn't be too cumbersome to have to open IE and enable Java for the occasions I use zipforms. Or is there another preferred method? Thanks, John

Thanks Alice. I did go to add/remove programs but the java plugin doesn't show up there. I don't mind leaving it disabled if that's the best way. However now another issue has cropped up. I use a website, zipform.com, that apparently uses Java. So I apparently do need Java. Is there a recommended policy to use Java as safely as possible? Does it make sense to install Java only on IE (which I don't normally use) and leave it disabled except for when I need to use zipform.com? I don't use it that often and it wouldn't be too cumbersome to have to open IE and enable Java for the occasions I use zipforms. Or is there another preferred method? Thanks, John
cor-el
  • Top 10 Contributor
  • Moderator
13044 решења 119439 одговора
Постављено

You see such a message if you visit the plugin check page with Java disabled and Java isn't detected, so you can ignore that message.

You see such a message if you visit the plugin check page with Java disabled and Java isn't detected, so you can ignore that message. *http://www.mozilla.org/plugincheck/
AliceWyman
  • Moderator
195 решења 2266 одговора
Постављено

The message, Missing Java? For your safety, Firefox has disabled your outdated version of Java. Please upgrade to the latest version. on the PluginCheck page when you yourself disable the Java Platform plugin, or when Java isn't even installed, is a known bug, like cor-el said.

The Java Deployment Toolkit plugin npdeployJava1.dll is installed along with the main Java program but it isn't needed for Java applets to work on webpages . The file could be a leftover that wasn't removed when you uninstalled Java. On my Windows 7 x64 system, a leftover npdeployJava1.dll file located in the C:\Windows\SysWow64 folder wasn't removed when I uninstalled Java 7 in the past (to downgrade to Java 6). I had to rename the file to remove it from the Add-ons Manager. See http://kb.mozillazine.org/Issues_related_to_plugins#Plugin_location for more information.

If you need Java, Java 7 Update 11 is the current version and it includes a safety feature that enables Java to run with the high security setting by default. See http://www.oracle.com/technetwork/java/javase/7u11-relnotes-1896856.html

If you need more help installing, managing, or using Java, see

The message, ''Missing Java? For your safety, Firefox has disabled your outdated version of Java. Please upgrade to the latest version.'' on the [http://www.mozilla.com/en-US/plugincheck/ PluginCheck page] when you yourself disable the Java Platform plugin, or when Java isn't even installed, is a [http://kb.mozillazine.org/Java#Plugin_Check_reports_outdated_Java_has_been_disabled_when_it_is_up-to-date_or_when_Java_is_not_installed known bug], like cor-el said. The Java Deployment Toolkit plugin '''npdeployJava1.dll''' is installed along with the main Java program but it isn't needed for Java applets to work on webpages . The file could be a leftover that wasn't removed when you uninstalled Java. On my Windows 7 x64 system, a leftover npdeployJava1.dll file located in the C:\Windows\SysWow64 folder wasn't removed when I uninstalled Java 7 in the past (to downgrade to Java 6). I had to rename the file to remove it from the Add-ons Manager. See http://kb.mozillazine.org/Issues_related_to_plugins#Plugin_location for more information. If you need Java, Java 7 Update 11 is the current version and it includes a safety feature that enables Java to run with the high security setting by default. See http://www.oracle.com/technetwork/java/javase/7u11-relnotes-1896856.html If you need more help installing, managing, or using Java, see *http://kb.mozillazine.org/Java *[[Use the Java plugin to view interactive content on websites]]
Постављено

Власник питања

So is Java 7 update 11 considered safe? There's a lot in the news about Java being unsafe. My GF works at a college which just sent out a notice advising everyone to disable Java on their pc's. I know Oracle will say it's safe, but what do savvy computer users say?

So is Java 7 update 11 considered safe? There's a lot in the news about Java being unsafe. My GF works at a college which just sent out a notice advising everyone to disable Java on their pc's. I know Oracle will say it's safe, but what do savvy computer users say?
AliceWyman
  • Moderator
195 решења 2266 одговора
Постављено

You also asked, Does it make sense to install Java only on IE (which I don't normally use) and leave it disabled except for when I need to use zipform.com?

The Java installer includes the activeX control needed for Internet Explorer and the Mozilla plugin for Firefox and other browsers, so you only need to install Java once for Java to be enabled in all browsers. (That's different than Flash, which has a separate activeX installer for Internet Explorer and a plugin installer for Firefox and other browsers.) You could leave Java disabled in Firefox and then use Internet Explorer when you want to use a site that needs Java, which is actually the recommendation here:

Quote:


If you need Java for a specific Web site, consider adopting a two-browser approach. If you normally browse the Web with Firefox, for example, consider disabling the Java plugin in Firefox, and then using an alternative browser (Chrome, IE9, Safari, etc.) with Java enabled to browse only the site(s) that require(s) it.


You also asked, '' Does it make sense to install Java only on IE (which I don't normally use) and leave it disabled except for when I need to use zipform.com?'' The Java installer includes the activeX control needed for Internet Explorer and the Mozilla plugin for Firefox and other browsers, so you only need to install Java once for Java to be enabled in all browsers. (That's different than Flash, which has a separate activeX installer for Internet Explorer and a plugin installer for Firefox and other browsers.) You could leave Java disabled in Firefox and then use Internet Explorer when you want to use a site that needs Java, which is actually the recommendation here: *http://krebsonsecurity.com/2013/01/oracle-ships-critical-security-update-for-java/ Quote: ----- If you need Java for a specific Web site, consider adopting a two-browser approach. If you normally browse the Web with Firefox, for example, consider disabling the Java plugin in Firefox, and then using an alternative browser (Chrome, IE9, Safari, etc.) with Java enabled to browse only the site(s) that require(s) it. -----
Постављено

Одабрано решење

That helps, thanks. I'll install the latest version and go with the two-browser approach.

That helps, thanks. I'll install the latest version and go with the two-browser approach.