Претражи подршку

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Maps created with Google maps & embedded in Google Sites will not display.

  • 13 одговорa
  • 2 имају овај проблем
  • 40 прегледа
  • Последњи одговор послао rjungman

more options

Firefox 42, Mac OS X 10.10.5. Maps created with Google My Maps and embedded in a Google Site do not display.

Сви одговори (13)

more options

Do you want to give an example URL for a page that shows this problem?

If this was working fine in earlier versions of Firefox, two thoughts:

(1) It's always a good idea to clear cache and the site's cookies (steps below)

(2) If you are browsing the site in a private window, it might be Firefox's new Tracking Protection feature (see What happened to Tracking Protection?)


When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(A) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(B) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click/Ctrl+click a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?


Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. Whoops, Shift key is for Windows. On Mac, hold down the Option key.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Diagnose Firefox issues using Troubleshoot Mode)

Измењено од стране jscher2000

more options

I tested in safe mode - still did not display. Sample URL: https://sites.google.com/a/trinity.edu/kohfield-half-marathon/map-of-race-course

more options

Hmm, I can see it on Windows, but my setup is very customized, so it's possible that I've got something running that fixes a problem that otherwise might exist.

How much is loading for you -- are you getting nothing, or a header bar above a blank rectangle, etc.

The attached screenshot shows the NoScript drop-down and which sites' scripts are allowed to run (most of them) and which are blocked (Google Analytics). Can you think of any reason your Firefox might not load embedded content from those sites?

more options

I'm getting a header bar above a blank rectangle. (This all loads fine in Chrome & Safari).

I can't think of why Firefox might not load embedded content from those sites.

more options

If you right-click or Ctrl+click the wording "Training Run #1" and expand the This Frame menu and click Open Frame in New Tab, does the map display normally there?

more options

The header says only "Google Map", and when I right-click on that, there the choices are only as seen below.

more options

Thanks, I see, the entire iframe area is blank, not just the image. If you right-click or Ctrl+click the blank area, do you see This Frame on the context menu? If so, expand that and click Open Frame in New Tab. Does the map display normally there?

more options

Does opening the iframe with the map in a new tab work?

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

more options

No, the frame opens in a new tab as blank (and I'm on a Mac, not a Windows machine :-) I'm in Safe Mode - all add-ons disabled.

more options
more options
No, the frame opens in a new tab as blank
opening https://www.google.com/maps/d/embed?hl=en&hl=en&authuser=0&authuser=0&mid=z4XP7lwRDa_E.kBzncMX2M1wM in a new tab works

Could you compare those two URLs? They should be identical, but it sounds as though the one in the page itself is broken somehow.

more options

Do you run any Anti-Virus or other security software on your Mac?

Are there any special icons at the left end of the location/address bar?

more options

Yes, I run Sophos. No special icons to the left end of the location/address bar.