Kërkoni te Asistenca

Shmangni karremëzime gjoja asistence. S’do t’ju kërkojmë kurrë të bëni një thirrje apo të dërgoni tekst te një numër telefoni, apo të na jepni të dhëna personale. Ju lutemi, raportoni veprimtari të dyshimtë duke përdorur mundësinë “Raportoni Abuzim”.

Learn More

PgUp/PgDn no longer work after upgrading to Firefox 4

  • 14 përgjigje
  • 149 e kanë hasur këtë problem
  • 8 parje
  • Përgjigjja më e re nga d3howard

more options

I just upgraded from Firefox 3.6 to 4.0., and now the PgUp/PgDn keys (page up/page down) no longer work. Or rather, they act as though caret browsing (F7) is turned on, which it is not. (In caret browsing, PgUp is like the back button and PgDn is like the forward button.) To confirm that caret browsing is off, I've hit F7 and clicked No (multiple times), and also checked about:config, which shows that accessibility.browsewithcaret is false.

More info: (1) Options > Advanced > General > Always use the cursor keys to navigate within pages is unchecked, (2) the PgUp/PgDn keys also don't work when Firefox is restarted in Safe Mode, (3) they don't work on any webpage, (4) they do work correctly in other applications (Microsoft Word, etc.), (5) my operating system is Windows 7 Home Premium (64-bit), and (6) I run Microsoft Security Essentials (antivirus software).

Any ideas?

Could this be a bug? If so, what is the procedure for uninstalling Firefox 4 and returning to Firefox 3.6 -- without losing my bookmarks, add-ons, etc.?

Thanks!

I just upgraded from Firefox 3.6 to 4.0., and now the PgUp/PgDn keys (page up/page down) no longer work. Or rather, they act as though caret browsing (F7) is turned on, which it is not. (In caret browsing, PgUp is like the back button and PgDn is like the forward button.) To confirm that caret browsing is off, I've hit F7 and clicked No (multiple times), and also checked about:config, which shows that accessibility.browsewithcaret is false. More info: (1) Options > Advanced > General > Always use the cursor keys to navigate within pages is unchecked, (2) the PgUp/PgDn keys also don't work when Firefox is restarted in Safe Mode, (3) they don't work on any webpage, (4) they do work correctly in other applications (Microsoft Word, etc.), (5) my operating system is Windows 7 Home Premium (64-bit), and (6) I run Microsoft Security Essentials (antivirus software). Any ideas? Could this be a bug? If so, what is the procedure for uninstalling Firefox 4 and returning to Firefox 3.6 -- without losing my bookmarks, add-ons, etc.? Thanks!

Krejt Përgjigjet (14)

more options

Solved! I simply rebooted my computer, and the PgUp/PgDn keys came back to life. Duh. Let this be a reminder to everyone.

Guess I'll be staying with Firefox 4 after all.

more options

Not so fast! The PgUp/PgDn problem is back, exactly as before. Argh! I'll try rebooting again, but I now suspect this is a bug.

I hope a Firefox fix comes out soon, but meanwhile I'd like to downgrade to version 3.6. Any advice on doing this with minimal impact?

As a workaround, I'm using Space/Shift-Space to mimic PgUp/PgDn.

more options

I've got this problem now too and it's driving me nuts! I think I may just switch to another browser, FF4 has way way way too many bugs like this for me to comfortably use it as my everyday browser.

more options

I just wrote a longish reply, containing tidbits of useful information about this issue, when out of habit, I hit PgUp to look at something above, at which point the browser returned to the previous page, resulting in the loss of my content. Argh! This is a great example of how frustrating the bug can be.

Anyway, let's see if I can remember what I wrote.... This time I'll cut and paste from Word!

It appears that a lot of people are having problems with the new Firefox. I'm still on the fence about downgrading, hanging on for an upgrade fix, although it looks like it is possible to return to a previous version without loss of settings:

https://support.mozilla.com/en-US/que.../798804

https://support.mozilla.com/en-US/que.../795075

TonyE's replies are particularly helpful.

If you decide to downgrade and have lots of bookmarks, as I do, I highly recommend making a manual backup before proceeding:

http://support.mozilla.com/en-US/kb/Backing%20up%20and%20restoring%20boo...

And if you don't have a copy of a previous Firefox version, you can get one here:

http://www.mozilla.com/en-US/firefox/all-older.html

http://www.filehippo.com/download_firefox/

more options

See Bug 640587 – Page up/down behaviour changes to "page back/forward"

(please do not comment in bug reports; you can vote instead)

more options

I have the same problem. It appears to start when I go to youtube. As long as I stay out of youtube, pgUp and pgDn work like they should. I have found that, launching any other program as administrator solves the problem. At first, I tried using the program keyTweak, but found there was nothing it could do. After closing keyTweak, I noticed that the PgUp/PgDn keys were working. So now I always use keyTweak as the program which must be run by the administrator. I just open it and close it. and voilá! I use Win7 x64 Home Premium and am usually on a limited account.

more options

You may have a problem with the Flash plugin if it happens after visiting YouTube.

more options

It may be flash related, but I've just been playing a flash game and PgUp/PgDn still work fine. I watched a video on TED and they stopped working. Perhaps its something in the flash based video player. If it is, I don't think this will be resolved anytime soon. :( I just joined the HTML5 crowd on youtube and, at least, there the problem is "solved". :)

more options

Yeah this is happening on mine too, it's really annoying, I can deal with the pgdn and pgup not working, it's just the page back thing that is really frustrating - is there a way to just completely disable them?

more options

Yeah! It looks like the upgrade to Firefox 4.0.1 fixes the PgUp/PgDn problem.

And I've learned my lesson: Next time I'll skip the dot-zero upgrade and wait for the dot-one.

Thanks for commiserating.

more options

Well.. I'm using FF 4.0.1 and still the problem is not fixed... :(

more options

Sigh. The problem is back, just as before. I am such a foolish optimist.

Out of desperation, I followed the above link kindly provided by cor-el: Bug 640587.

I should have done this before. There is some nice detective work on the issue.

In summary, it appears the problem is related to hotkey software on Asus and other computers (I own an Asus UL80VT) and possibly activated by visits to YouTube.

Unfortunately, no resolution has yet been found.

Meanwhile, if you are as irritated about this as I am, I encourage you to register at Bugzilla and vote on Bug 640587 to raise its importance. I just did.

N.B.: To register, you must provide an email address, which you must then verify. This email address becomes publicly viewable, so you might want to use a disposable one.

Ndryshuar nga GordonW

more options

dmtf2010 nailed the problem here (https://bugzilla.mozilla.org/show_bug.cgi?id=640587#c48):

So, the solution is: 1. Go to about:config 2. Find ui.elantech_gesture_hacks.enabled 3. Change its value from -1 to 0 4. Restart FF 5. If you run into a bug that option was designed to fix (non-working page swipe gestures), install the latest Elantech driver (http://www.techspot.com/drivers/driver/file/information/14513/) and reboot.

I've tried his solution and, so far, so good. :)

more options

Worked for me too... but only after I pressed F7 to toggle "browse with caret" to the correct mode. http://kb.mozillazine.org/Accessibility.browsewithcaret