Kërkoni te Asistenca

Shmangni karremëzime gjoja asistence. S’do t’ju kërkojmë kurrë të bëni një thirrje apo të dërgoni tekst te një numër telefoni, apo të na jepni të dhëna personale. Ju lutemi, raportoni veprimtari të dyshimtë duke përdorur mundësinë “Raportoni Abuzim”.

Learn More

Using system wide proxy setting in Linux

  • 3 përgjigje
  • 0 e kanë hasur këtë problem
  • 62 parje
  • Përgjigjja më e re nga hinko.kocevar

more options

I have the HTTP_PROXY, HTTPS_PROXY and FTP_PROXY (and their lowercase counterparts) exported and then the firefox binary is started from the shell script. The settings in firefox say it will 'Use system proxy settings'. Nevertheless I do not see the proxy being used as I can not access the web pages that need the proxy. The 'about:config' also does not show that firefox picked up any proxy related information from the shell environment.

I know the proxy address is correct because if I use brave browser instead of firefox (same shell script that launches brave) I can reach the web pages behind the proxy as expected.

I have the HTTP_PROXY, HTTPS_PROXY and FTP_PROXY (and their lowercase counterparts) exported and then the firefox binary is started from the shell script. The settings in firefox say it will 'Use system proxy settings'. Nevertheless I do not see the proxy being used as I can not access the web pages that need the proxy. The 'about:config' also does not show that firefox picked up any proxy related information from the shell environment. I know the proxy address is correct because if I use brave browser instead of firefox (same shell script that launches brave) I can reach the web pages behind the proxy as expected.

Zgjidhje e zgjedhur

If your proxy is set up in the following format: "<proxy_user>:<proxy_password>@<proxy_host>", you have to add a scheme (http://).

Lexojeni këtë përgjigje brenda kontekstit 👍 1

Krejt Përgjigjet (3)

more options

If the 'Manual proxy configuration' is used instead I can access the web pages behind the proxy. But this is not what I want to do; I would like firefox to pick up the system wide proxy settings.

E dobishme?

more options

Zgjidhja e Zgjedhur

If your proxy is set up in the following format: "<proxy_user>:<proxy_password>@<proxy_host>", you have to add a scheme (http://).

E dobishme?

more options

I only have "<proxy_host>:<proxy_port>". Nevertheless adding "http://" in front of it solved the issue for me.

Would be really nice if this was documented somewhere (apologizes if it is , but I couldn't spot it)..

E dobishme?

Bëni një pyetje

Duhet të bëni hyrjen te llogaria juaj që t’i përgjigjeni postimeve. Ju lutemi, filloni me një pyetje të re, nëse nuk keni ende një llogari.