Kërkoni te Asistenca

Shmangni karremëzime gjoja asistence. S’do t’ju kërkojmë kurrë të bëni një thirrje apo të dërgoni tekst te një numër telefoni, apo të na jepni të dhëna personale. Ju lutemi, raportoni veprimtari të dyshimtë duke përdorur mundësinë “Raportoni Abuzim”.

Learn More

Firefox constantly crashing

  • 5 përgjigje
  • 13 e kanë hasur këtë problem
  • 146 parje
  • Përgjigjja më e re nga jscher2000

more options

For about a month or so Firefox has been crashing constantly. At first I'd get errors about the plug-in container. Someone suggested deleting that, but it didn't solve the problem. I've removed and reinstalled both Firefox and flash but that didn't fix it. Although I don't get errors about the plug-in container anymore, now it often just freezes, or it will tell me that firefox has crashed.

I've tried most of the other remedies that were suggested on this forum. I toggled hardware acceleration, I've updated my graphics card drivers, I've re-installed without all the plug-ins.

Now that I reinstalled there doesn't seem to be any record of crash reports either, even though it has crashed 4-5 times since the reinstall. Do I need to do something to enable crash reports?

Thanks for any help you can give!!

Krejt Përgjigjet (5)

more options

Update Software

Mozilla recommends updating the software on your system if Firefox is crashing. Here is a list of everything you should update:

  • Firefox: Click the Firefox menu, point to Help, and select About Firefox. Download and install any available updates.
  • Plug-ins: Visit the Firefox plug-in update check page. The page will scan your browser for outdated plugins. Follow the links to download and install updates for any outdated plugins.
  • Extensions and Themes: Click the Firefox button, click Add-ons, and select Extensions. Click the gear menu and select Check for Updates. Install any updated add-ons.
  • Windows: Use Windows Update to ensure Windows is up-to-date.
  • Graphics Drivers: Install updated graphics drivers to fix problems with hardware acceleration.
  • Internet Security Software: Install the latest versions of any firewalls, antivirus programs, Internet security suites, and other security applications installed on your system.
more options

Thanks for the reply! I've already updated all of these and now I'm running a clean install of Firefox with no plug-ins, yet I'm still getting crashes.

more options

Could you give a link to one of the crash reports?

more options

mimi89999 said

Could you give a link to one of the crash reports?

I checked the log but there were no crash reports saved. I'm assuming they were all erased after I did a clean install. Now it's still crashing but not saving reports. Is there a way I can turn that feature on?

Ndryshuar nga Tri_109

more options

If you deleted your old profile folder (under AppData\Roaming) then you probably deleted the old crash reports.

Which dialog do you get when Firefox crashes: the Mozilla Crash Reporter or the standard Windows dialog? If you are getting the Windows dialog, Firefox may not be able to capture the data.


This is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case:

(1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily.

(2) Disable hardware acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here:

"3-bar" menu button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

That takes effect the next time you exit and start Firefox up again.

(B) In Flash, right-click the media and choose Settings, then the first mini-tab and uncheck the box to use hardware acceleration. More information in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista and higher)

The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. You can disable it by creating or editing a settings file. The following pages/posts provide different approaches for that:

Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect.

Any improvement?