Iskanje po podpori

Izogibajte se prevarantski tehnični podpori. Nikoli vam ne bomo naročili, da pokličete telefonsko številko ali nam pošljete osebne podatke. Sumljivo dejavnost prijavite z gumbom »Prijavi zlorabo«.

Learn More

Wrong font displays

more options

When I download new font families, sometimes firefox displays the incorrect font on previously working web pages. The attached image shows what the web page should look like on top, and how firefox is displaying the wrong font on the bottom. This happens on multiple web pages, and this is the second time this is happening to me. The previous time this happened, I uninstalled the font that was being wrongly displayed and everything worked as normal afterward. This time I tried to find and uninstall the font, and wound up uninstalling a bunch of fonts and still having the issue.

I'm aware that there's a setting for me to choose which fonts websites display, and while this allows the correct font to show, it also causes other display issues; as shown in my second image, symbols turn into letters.

Is there another way to resolve this? I'd like to have a solution in case this occurs again.

When I download new font families, sometimes firefox displays the incorrect font on previously working web pages. The attached image shows what the web page should look like on top, and how firefox is displaying the wrong font on the bottom. This happens on multiple web pages, and this is the second time this is happening to me. The previous time this happened, I uninstalled the font that was being wrongly displayed and everything worked as normal afterward. This time I tried to find and uninstall the font, and wound up uninstalling a bunch of fonts and still having the issue. I'm aware that there's a setting for me to choose which fonts websites display, and while this allows the correct font to show, it also causes other display issues; as shown in my second image, symbols turn into letters. Is there another way to resolve this? I'd like to have a solution in case this occurs again.
Priloženi posnetki zaslona

Vsi odgovori (1)

more options

Firefox on Windows has known issues with looking bad when using Helvetica Neue. If you need that font for other applications, the easiest workaround is to force Firefox to substitute a different font when pages require Helvetica Neue. There are two ways to do this that are more surgical than the brute force method you mentioned:

(A) Limit Firefox to using Windows "system" fonts plus web fonts. In other words, Firefox won't look for fonts beyond its defined list of Windows system fonts.

(B) Inject a custom style rule into web pages that redirects requests for Helvetica Neue to a similar sans-serif font such as Arial.

Here are the details for these options. You can try one out, see how you like it, then undo that and switch to the other if you like.

For (A): Limiting Use of User-Installed Fonts

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we have had this setting for a while now and I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste layout.css.font-visibility and pause while the list is filtered

Firefox should list four preferences.

(3) Double-click the layout.css.font-visibility.standard preference (or click the pencil button) to display an editing field, and choose a lower value, then press Enter or click the blue check mark button to save the change. (Repeat with the layout.css.font-visibility.private preference.)

These are the recognized values:

  • 1 = only use base system fonts
  • 2 = also use fonts from optional language packs
  • 3 = also use user-installed fonts (default for non-private contexts)

That should take effect after a normal exit/restart of Firefox, but sometimes Firefox holds on to old settings information in the Startup cache. There is a button on the Troubleshooting Information page to flush that while restarting Firefox. Either:

  • "3-bar" menu button > Help > More Troubleshooting Information
  • (menu bar) Help > More Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the upper right corner, look for the third button:

For (B): User-specified Font Override

See the detailed steps in this reply: https://support.mozilla.org/en-US/questions/1389044#answer-1541185

Spremenil jscher2000 - Support Volunteer